summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorAwesomeAdam54321 <adam.faiz@disroot.org>2025-01-02 08:39:59 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2025-01-07 23:53:23 +0800
commit2abd8660f7a741769cde0cc62057ab8509ba5aa1 (patch)
treeeecf86cb8fbd49328bde88e9ed7a2aa1d4948684 /gnu/packages/game-development.scm
parente5f68e3e474a6ce5e9c5ca6b24bdc2364ef42991 (diff)
gnu: inform: Update to 6.42.
* gnu/packages/game-development.scm (inform): Update to 6.42. Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 89f1578a698..12d58cd1cf8 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2630,22 +2630,18 @@ people base their games, ports to new platforms, and other projects.")
(license license:gpl2))))
(define-public inform
- ;; The latest release does not yet have a build system.
- ;; This commit is the earliest to have one.
- (let ((commit "20cbfff96015938809d0e3da6cd0d83b76d27f14")
- (revision "0"))
(package
(name "inform")
- (version (git-version "6.41" revision commit))
+ (version "6.42")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://jxself.org/git/inform.git")
- (commit commit)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "19z8pgrj1s2irany5s6xxwsm3bdnri1as46fdi16zdp4aah523jy"))))
+ (base32 "1gb7b8y4qq9n3r4giqr4shzn3xli6aiaax7k4lzlgic7w1x3zjfl"))))
(build-system gnu-build-system)
(native-inputs (list autoconf automake))
(synopsis "The Inform 6 compiler")
@@ -2654,7 +2650,7 @@ people base their games, ports to new platforms, and other projects.")
This version of the compiler has been modified slightly to work better when the
Inform standard library is in a non-standard location.")
(home-page "https://jxself.org/git/inform.git")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public informlib
(package