summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-27 09:14:20 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-27 09:39:12 +0900
commitce6f571fbe9f9426ebcc11c84c2a413aa22b877c (patch)
tree91f3d63ba43b08175eca6fa7bffe30d610978ec8 /gnu/packages/freedesktop.scm
parentd8298b37af7577aa3fba6bc45048d04a33f59b1f (diff)
Revert "gnu: xdg-desktop-portal: Update to 1.18.4."
This reverts commit 1b4304ea29296e25026361ecf19226cf2f554836. This broke setting themes in GNOME 44.1. Reported-by: Ada Stevenson <adanskana@gmail.com> Change-Id: Iaa8632a743d6fefd46f6415010b33f69bd6d2a04
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm25
1 files changed, 10 insertions, 15 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 289c4ea281..2a78895a20 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -39,7 +39,6 @@
;;; Copyright © 2024 aurtzy <aurtzy@gmail.com>
;;; Copyright © 2024 Dariqq <dariqq@posteo.net>
;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
-;;; Copyright © 2024 dan <i@dan.games>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -137,7 +136,6 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages video)
- #:use-module (gnu packages virtualization)
#:use-module (gnu packages w3m)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
@@ -3012,7 +3010,7 @@ compatible with the well-known scripts of the same name.")
(define-public xdg-desktop-portal
(package
(name "xdg-desktop-portal")
- (version "1.18.4")
+ (version "1.16.0")
(source
(origin
(method url-fetch)
@@ -3021,21 +3019,18 @@ compatible with the well-known scripts of the same name.")
version "/xdg-desktop-portal-" version ".tar.xz"))
(sha256
(base32
- "0r8y8qmzcfj7b7brqcxr9lg8pavfds815ffvj0kqc378fhgaln5q"))
- ;; Disable portal tests since they try to use fuse.
- (patches (search-patches "xdg-desktop-portal-disable-portal-tests.patch"))))
- (build-system meson-build-system)
+ "06cczlh39kc41rvav06v37sad827y61rffy3v29i918ibj8sahav"))))
+ (build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
("glib:bin" ,glib "bin")
- ("gettext" ,gettext-minimal)
- ("python" ,python)
- ("python-dbusmock" ,python-dbusmock)
- ("python-pytest" ,python-pytest)
- ("python-pytest-xdist" ,python-pytest-xdist)))
+ ("which" ,which)
+ ("gettext" ,gettext-minimal)))
(inputs
- `(("bubblewrap" ,bubblewrap)
- ("gdk-pixbuf" ,gdk-pixbuf)
+ `(("gdk-pixbuf" ,gdk-pixbuf)
("glib" ,glib)
("flatpak" ,flatpak)
("fontconfig" ,fontconfig)
@@ -3047,7 +3042,7 @@ compatible with the well-known scripts of the same name.")
("fuse" ,fuse)))
(arguments
`(#:configure-flags
- (list "-Dsystemd=disabled")
+ (list "--with-systemd=no")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'po-chmod