summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-12-05 15:45:45 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2025-01-05 20:28:15 -0500
commitb7767304327cf3965a59cc4ff85805bb852c9d2e (patch)
tree292e3f81104c52a4460a6bd5582c4d776cc88885 /gnu/packages/freedesktop.scm
parent23231c296fb2c2af8c1c0a6ead1dd6f0833f7c45 (diff)
gnu: wayland-protocols: Update to 1.38.
* gnu/packages/freedesktop.scm (wayland-protocols): Update to 1.38. [source]: Switch to git-fetch. [properties]: Remove release-monitoring-url. Co-authored-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Change-Id: Iaa4209eab3a467159a58d2fbedb564b1b0e5ca16
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index f9fa9f751e..9567433783 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1462,15 +1462,16 @@ fullscreen) or other display servers.")
(define-public wayland-protocols
(package
(name "wayland-protocols")
- (version "1.37")
+ (version "1.38")
(source (origin
- (method url-fetch)
- (uri (string-append "https://gitlab.freedesktop.org/wayland/"
- name "/-/releases/" version "/downloads/"
- name "-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/wayland/wayland-protocols")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "09pk3qhpc29x1a6srpqqw9dcvalg33vfmp14d276is7j4klrn3m7"))))
+ "1aik5zmpjwhxsfv9aa88sg95s0mg6yvy2cbqbd1xhigfbnq271zb"))))
(build-system meson-build-system)
(inputs
(list wayland))
@@ -1485,9 +1486,6 @@ functionality not available in the Wayland core protocol. Such protocols either
add completely new functionality, or extend the functionality of some other
protocol either in Wayland core, or some other protocol in wayland-protocols.")
(home-page "https://wayland.freedesktop.org")
- (properties
- '((release-monitoring-url
- . "https://wayland.freedesktop.org/releases.html")))
(license license:expat)))
(define-public wayland-protocols-next