summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-11-06 08:38:38 +0800
committerHilton Chain <hako@ultrarare.space>2024-12-08 15:28:42 +0800
commit0e79732c3f66de6b1eaace67c08264cfe9296a50 (patch)
tree6d3d9a22ce213a18e30f9e073e57e5f913c13cd3 /gnu/packages/freedesktop.scm
parent9a56e3e0ada4d072442f4ca3f5cef3f97800459c (diff)
gnu: Add hyprland-protocols.
* gnu/packages/wm.scm (hyprland-protocols): New variable. Change-Id: If986f2b5f8c0070807484e60431bb4c47f901edc
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index bb6a721a41..521a645a92 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1340,6 +1340,26 @@ For information about libevdev, see:
Python.")
(license license:lgpl2.0)))
+(define-public hyprland-protocols
+ (package
+ (name "hyprland-protocols")
+ (version "0.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hyprwm/hyprland-protocols")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0x86w7z3415qvixfhk9a8v5fnbnxdydzx366qz0mpmfg5h86qyha"))))
+ (build-system meson-build-system)
+ (home-page "https://github.com/hyprwm/hyprland-protocols")
+ (synopsis "Wayland protocol extensions for Hyprland")
+ (description
+ "This package provides Wayland protocol extensions for Hyprland.")
+ (license license:bsd-3)))
+
(define-public hyprwayland-scanner
(package
(name "hyprwayland-scanner")