summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-11 08:33:02 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:41 +0000
commitfdc0fefd46a45b70784a4e3f8900cbe593426a9e (patch)
tree13c3736334bde1c3ec75d67f4e430396e23eed3f /gnu/packages/fontutils.scm
parentca945f7c35bbc5d05a6ad7e5baa15f79e0fd0ecc (diff)
build-system/pyproject: Use python-sans-pip-wrapper as default-python.
Also adds python-setuptools and python-wheel to relevant packages, either to native-inputs or to propagated inputs if the pkg_resources Python module is loaded at runtime. * guix/build-system/pyproject.scm (default-python): Default to python-sans-pip-wrapper. Change-Id: I2d986c2225114f54459dd6bb360913106e52cdf4
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 614d62f439..c7443fe1a1 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -532,7 +532,11 @@ converts any cubic curves to quadratic. The most useful function is probably
(sha256
(base32 "1rg2997af8blvswlwif0kpz2vxrlh555gzqslz6yv9y7i7v8lphl"))))
(build-system pyproject-build-system)
- (native-inputs (list python-pytest python-setuptools-scm))
+ (native-inputs
+ (list python-pytest
+ python-setuptools-scm
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-booleanoperations
python-cffsubr
@@ -679,7 +683,8 @@ process. FontParts is the successor of RoboFab.")
"--ignore=tests/builder/interpolation_test.py")))
(native-inputs
(list python-setuptools-scm
-
+ python-setuptools
+ python-wheel
;; For tests.
python-pytest
python-xmldiff))
@@ -859,6 +864,7 @@ suite of the @code{psautohint} package.")
python-pytest-cov
python-pytest-xdist
python-setuptools-scm
+ python-setuptools
python-wheel))
(home-page "https://github.com/adobe-type-tools/psautohint")
(synopsis "Adobe's PostScript autohinter")
@@ -1782,8 +1788,13 @@ with @samp{nameIDs}.")
(base32 "0yx4i8q5rfyqhr2fj70a7z1bp1jv7bdlr64ww9z4nv9ycbda4x9j"))))
(build-system pyproject-build-system)
(native-inputs
- (list python-pytest python-setuptools-scm))
- (propagated-inputs (list python-attrs python-fonttools))
+ (list python-pytest
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
+ (propagated-inputs
+ (list python-attrs
+ python-fonttools))
(home-page "https://github.com/fonttools/ufoLib2")
(synopsis "Unified Font Object (UFO) font processing library")
(description "The ufoLib2 Python library is meant to be a thin