summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorSergey Trofimov <sarg@sarg.org.ru>2024-12-25 15:01:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:26 +0100
commit37e8eeaafbbfbf260cfbfe2ca5aca08bbedeae35 (patch)
tree14d2761412440515ade440a5320dd97ea7c8beb8 /gnu/packages/finance.scm
parente2945c650d14a6c3b74a717d4b6fda4573a941a1 (diff)
gnu: fava: Update to 1.27.
* gnu/packages/finance.scm (fava): Update to 1.27. [arguments] <phases>: Remove 'relax-requirements, and 'set-home. [native-inputs]: Remove python-chardet, python-dateutil, and python-setuptootls-scm. Add python-babel, python-mypy, python-pytest-cov, python-setuptootls, python-twine, python-types-setuptootls, python-types-simplejson, and python-wheel. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Iee27197ece9685c500afe0dedb8ba33e02eb1ea1
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm33
1 files changed, 12 insertions, 21 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 15f85a10c05..68dba4ed1a9 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -124,6 +124,7 @@
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-web)
@@ -2036,29 +2037,14 @@ generate a variety of reports from them, and provides a web interface.")
(define-public fava
(package
(name "fava")
- ;; XXX: A newer version requires Flask > 2.2, which is not available in
- ;; Guix yet.
- (version "1.24.4")
+ (version "1.27")
(source
(origin
(method url-fetch)
(uri (pypi-uri "fava" version))
(sha256
- (base32 "1iwha9vx223iiyjqbixpz1lp8q766ikhi7xcap3pscjhldxlym4j"))))
+ (base32 "0cw3pmyrknsw0h4w3v9vyk6wrii68zwkywsyyvjzyl2qz3xq8srk"))))
(build-system pyproject-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- (substitute* "setup.cfg"
- ((">=8,<10") ">8"))))
- ;; Tests write to $HOME.
- ;; FileNotFoundError: [Errno 2] No such file or directory
- (add-before 'check 'set-home
- (lambda _
- (setenv "HOME" "/tmp"))))))
(propagated-inputs
(list beancount
python-babel
@@ -2072,10 +2058,15 @@ generate a variety of reports from them, and provides a web interface.")
python-simplejson
python-werkzeug))
(native-inputs
- (list python-pytest
- python-chardet
- python-dateutil
- python-setuptools-scm))
+ (list python-babel
+ python-mypy
+ python-pytest
+ python-pytest-cov
+ python-setuptools
+ python-twine
+ python-types-setuptools
+ python-types-simplejson
+ python-wheel))
(home-page "https://beancount.github.io/fava/")
(synopsis "Web interface for the accounting tool Beancount")
(description "Fava is a web interface for the double-entry bookkeeping