summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorNoé Lopez <noelopez@free.fr>2024-11-07 17:50:03 +0100
committerLudovic Courtès <ludo@gnu.org>2024-11-23 16:25:44 +0100
commitb143ec8edacbdc2afb9e0c8fb4e8940b861be01a (patch)
treef3109bfe2c3b84577c99f4a7d356fb180a584fbb /gnu/packages/file-systems.scm
parent2d3bf6a2a33fae685c03320f289d73ba3e7275f6 (diff)
gnu: appimage: New packages for the appimage runtime.
* gnu/packages/appimage.scm (gnu packages appimage): New module. (appimage-type2-runtime): New variable. * gnu/packages/file-systems.scm (squashfuse-for-appimage): New variable. * gnu/packages/linux.scm (fuse-for-appimage): New variable. Change-Id: I857a8eb5399a6a493e52db70b6c8cf0c71360930 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 059bdf67a9..e36751e774 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -2059,6 +2059,27 @@ almost all features of the SquashFS format, yet is still fast and
memory-efficient.")
(license license:bsd-2)))
+(define-public squashfuse-for-appimage
+ (package
+ (inherit squashfuse)
+ (arguments
+ (list
+ #:configure-flags
+ #~'("CFLAGS=-ffunction-sections -fdata-sections -Os -no-pie"
+ "LDFLAGS=-static")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-private-headers
+ (lambda _
+ (install-file "fuseprivate.h"
+ (string-append #$output
+ "/include/squashfuse/")))))))
+ (inputs (list fuse-for-appimage
+ `(,zstd "lib")
+ `(,zstd "static")
+ `(,zlib "out")
+ `(,zlib "static")))))
+
(define-public tmsu
(package
(name "tmsu")