summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2024-11-25 23:00:14 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2024-11-26 15:21:44 +0100
commitf8979b4bcc8772d02640f6f665b4195380d57df9 (patch)
treeb05d6918a0828587609fb8287547ff25c80b43aa /gnu/packages/engineering.scm
parente11ab2a6e9628af6c37d4ae5e0faabde79bcea34 (diff)
gnu: freecad: Update to 1.0.0.
* gnu/packages/patches/freecad-vtk-9.3.patch: Has been upstreamed, remove. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/engineering (freecad)[source]: Update to 1.0.0, remove patches, add snippet to unbundle some 3rdparty code. [native-inputs]: Add c++-gsl. [inputs]: Add onsdel-solver, yaml-cpp. [configure-flags]: Add some flags. Change-Id: I3005a3b5cccc8aae4129a49e123fd5ab8293b3f2 Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm25
1 files changed, 19 insertions, 6 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 699b14dd901..339751a7365 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2960,7 +2960,7 @@ dynamics is used by FreeCAD 1.0.0 for its new Assembly workbench.")
(define-public freecad
(package
(name "freecad")
- (version "0.21.2")
+ (version "1.0.0")
(source
(origin
(method git-fetch)
@@ -2969,12 +2969,19 @@ dynamics is used by FreeCAD 1.0.0 for its new Assembly workbench.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0s720q6vxlh78jzahqp69nl8wagb42l05dym5aqhfnr31dx666hc"))
- ;; https://github.com/FreeCAD/FreeCAD/pull/11496
- (patches (search-patches "freecad-vtk-9.3.patch"))))
+ (base32 "0wwymcfgi0cybj7m6awflk8c7n6iy97lpgpfhfncx3zwvjrxv588"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; not required, because 3D mouse support if OFF
+ (delete-file-recursively "src/3rdParty/3Dconnexion")
+ (delete-file-recursively "src/3rdParty/GSL") ;; c++-gsl
+ (delete-file-recursively "src/3rdParty/OndselSolver") ;; ondsel-solver
+ (delete-file-recursively "src/3rdParty/OpenGL"))))) ;; glext.h from mesa
(build-system qt-build-system)
(native-inputs
- (list doxygen
+ (list c++-gsl
+ doxygen
graphviz
qttools-5
pkg-config
@@ -3004,6 +3011,7 @@ dynamics is used by FreeCAD 1.0.0 for its new Assembly workbench.")
libxmu
lz4
netcdf
+ ondsel-solver
opencascade-occt
openmpi
proj
@@ -3026,14 +3034,19 @@ dynamics is used by FreeCAD 1.0.0 for its new Assembly workbench.")
tbb-2020 ; Same version as opencascade-occt
vtk
xerces-c
+ yaml-cpp
zlib))
(arguments
- `(#:tests? #f ; Project has no tests
+ `(#:tests? #f ;; Project has tests, but they are a pain to build
#:configure-flags
,#~(list
"-DBUILD_QT5=ON"
"-DBUILD_FLAT_MESH:BOOL=ON"
"-DBUILD_ENABLE_CXX_STD:STRING=C++17"
+ "-DENABLE_DEVELOPER_TESTS=OFF" ;; see the above: #:tests? comment
+ "-DFREECAD_USE_EXTERNAL_ONDSELSOLVER=ON" ;; unbundle ondsel-solver
+ ;; Do not try to install modules into system python
+ "-DINSTALL_TO_SITEPACKAGES=OFF"
(string-append "-DCMAKE_INSTALL_LIBDIR=" #$output "/lib"))
#:phases
(modify-phases %standard-phases