summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-07-28 14:32:18 +0000
committerjgart <jgart@dismail.de>2024-07-29 13:48:50 -0500
commitf093ea3f2e62341d8acfbfcb9761e993d785a8dd (patch)
treeb333fea353551f7685301ea29de42c9077555698 /gnu/packages/engineering.scm
parentfdc6274de5b1d617fcabb3f3af9d2c0dd2a6520d (diff)
gnu: Add python-motulator.
* gnu/packages/engineering.scm (python-motulator): New variable. Change-Id: I96af42be634a4ceaffe011d81177d42d48616eb2 Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 5f380ceb23..f411d4ac1e 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2996,6 +2996,32 @@ arithmetic operations on fields, entity location functionalities, and
interpolation toolkit.")
(license license:gpl3+)))
+(define-public python-motulator
+ (package
+ (name "python-motulator")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "motulator" version))
+ (sha256
+ (base32 "01qv4d4rgkwk653vz1qz1nmakniv86572j5ikrxwd63rwv5ckggf"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; there are no tests
+ (propagated-inputs (list python-matplotlib python-numpy python-scipy))
+ (native-inputs (list python-hatchling
+ python-ipykernel
+ python-toml))
+ (home-page "https://aalto-electric-drives.github.io/motulator/")
+ (synopsis "Motor Drive Simulator in Python")
+ (description "This package includes simulation models for an induction
+motor, a synchronous reluctance motor, and a permanent-magnet synchronous
+motor. The motor models are simulated in the continuous-time domain while the
+control algorithms run in discrete time. The default solver is the explicit
+Runge-Kutta method of order 5(4) from @code{scipy.integrate.solve_ivp.}")
+ (license license:expat)))
+
(define-public cgns
(package
(name "cgns")