summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-07-16 23:38:22 +0000
committerjgart <jgart@dismail.de>2024-07-16 20:35:26 -0500
commita384d064794729715f18d202ece713b6b8142b47 (patch)
tree478cf0a8c2600b4e7a8f2f788df674c2d0ec0121 /gnu/packages/engineering.scm
parentb0edf212e1195a36a7fb1f086b2399569afc6a7e (diff)
gnu: Add python-lcapy.
* gnu/packages/engineering.scm (python-lcapy): New variable. Change-Id: Ieca7f9e717dd1cd59ebe124bd51937680f8c9eb5 Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 2875d453304..c198d959533 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2723,6 +2723,42 @@ Newton-Raphson power flow solvers in the C++ library lightsim2grid, and the
Microwave engineering.")
(license license:bsd-3)))
+(define-public python-lcapy
+ (package
+ (name "python-lcapy")
+ (version "1.23")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "lcapy" version))
+ (sha256
+ (base32 "13swd2nd2s20hixy4as924sr223flcvcy9zw3qlzsrcvhppzb84n"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; This test fails by FileNotFoundError (a schematic file), possibly
+ ;; because it's not included in PyPI.
+ #:test-flags #~(list "-k" "not test_circuitgraph")))
+ (propagated-inputs (list python-ipython
+ python-matplotlib
+ python-networkx
+ python-numpy
+ python-property-cached
+ python-scipy
+ python-setuptools
+ python-sympy
+ python-wheel))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/mph-/lcapy")
+ (synopsis "Symbolic linear circuit analysis")
+ (description "Lcapy is a Python package for linear circuit analysis. It
+uses SymPy for symbolic mathematics.
+
+Lcapy can symbolically analyse circuits described with netlists or by
+series/parallel combinations of components. It can also manipulate
+ontinuous-time and discret-time expressions.")
+ (license license:lgpl2.1+)))
+
(define-public openscad
(package
(name "openscad")