summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2024-02-22 20:47:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:25 +0000
commit6d97c15911a51d29f91e3656f9c4ab38e08d7f21 (patch)
treea42bcc8f38f2532ca0218d92323c993729912961 /gnu/packages/engineering.scm
parent1ef178c644178304b24bd29c7563ab0529c15f8f (diff)
gnu: Add python-setuptools/python-wheel where necessary.
Changes to pyproject-build-system require explicit dependency on setuptools/wheel. Change-Id: Icd7699fc1dc56e974ae7568f2ae916dbf876bea5
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index c829ece846..52cec2a095 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -4786,11 +4786,18 @@ more.")
"0bazk3k2dyzlrh7yxs4pc76m5ysm7riia3ncg7as3xr4y9dy29bx"))))
(build-system pyproject-build-system)
(native-inputs
- (list python-pytest-asyncio python-pytest-runner python-asynctest
- python-pytest-mock))
+ (list python-asynctest
+ python-pytest-asyncio
+ python-pytest-mock
+ python-pytest-runner
+ python-setuptools
+ python-wheel))
(propagated-inputs
- (list python-aiofiles python-aiosqlite python-cryptography
- python-importlib-metadata python-dateutil python-pytz
+ (list python-aiofiles
+ python-aiosqlite
+ python-cryptography
+ python-dateutil python-pytz
+ python-importlib-metadata
python-sortedcontainers))
(synopsis "OPC UA / IEC 62541 client and server library")
(description "This package provides an OPC UA / IEC 62541 client and