summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-28 01:12:34 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-10-07 01:20:21 +0900
commit3f20214662dd9b5525d0fc495d5c43f606ffb665 (patch)
tree7cbd613b851c17cd36d68b9e6985a9351787c99f /gnu/packages/emulators.scm
parent9875fbfeba8ce0ad7916c03365eded648bbb0275 (diff)
gnu: retroarch: Extend search-path support.
* gnu/packages/patches/retroarch-improved-search-paths.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/emulators.scm (retroarch) [source]: Apply patch. [configure-flags]: Add '--disable-update_assets'. [native-search-paths]: New search paths for LIBRETRO_ASSETS_DIRECTORY, LIBRETRO_AUTOCONFIG_DIRECTORY, LIBRETRO_VIDEO_FILTER_DIRECTORY and LIBRETRO_VIDEO_SHADER_DIRECTORY. Fixes: https://issues.guix.gnu.org/38439 Change-Id: I593c223ad887277e4637adc8d7ef7439f9ced611
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm31
1 files changed, 26 insertions, 5 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 35a7e845d3..a3a63c4545 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1618,7 +1618,8 @@ physical device and the RetroPad virtual controller.")
(file-name (git-file-name name version))
(sha256
(base32 "15nh4y4vpf4n1ryhiy4fwvzn5xz5idzfzn9fsi5v9hzp25vbjmrm"))
- (patches (search-patches "retroarch-unbundle-spirv-cross.patch"))))
+ (patches (search-patches "retroarch-improved-search-paths.patch"
+ "retroarch-unbundle-spirv-cross.patch"))))
(build-system gnu-build-system)
(arguments
(list
@@ -1651,6 +1652,8 @@ physical device and the RetroPad virtual controller.")
;; Non-free software are available through the core updater,
;; disable it. See <https://issues.guix.gnu.org/38360>.
"--disable-update_cores"
+ ;; The assets are provided via the `retroarch-assets' package.
+ "--disable-update_assets"
"--disable-builtinmbedtls"
"--disable-builtinbearssl"
"--disable-builtinzlib"
@@ -1669,6 +1672,10 @@ physical device and the RetroPad virtual controller.")
"--disable-stb_image"
"--disable-stb_vorbis"
"--disable-xdelta"))))))
+ (native-inputs
+ (list pkg-config
+ wayland-protocols
+ which))
(inputs
(list alsa-lib
eudev
@@ -1697,13 +1704,27 @@ physical device and the RetroPad virtual controller.")
vulkan-loader
wayland
zlib))
- (native-inputs
- (list pkg-config wayland-protocols which))
(native-search-paths
(list (search-path-specification
(variable "LIBRETRO_DIRECTORY")
- (separator #f) ; single entry
- (files '("lib/libretro")))))
+ (separator #f) ;single entry
+ (files '("lib/libretro")))
+ (search-path-specification
+ (variable "LIBRETRO_ASSETS_DIRECTORY")
+ (separator #f) ;single entry
+ (files '("share/libretro/assets")))
+ (search-path-specification
+ (variable "LIBRETRO_AUTOCONFIG_DIRECTORY")
+ (separator #f) ;single entry
+ (files '("share/libretro/autoconfig")))
+ (search-path-specification
+ (variable "LIBRETRO_VIDEO_FILTER_DIRECTORY")
+ (separator #f) ;single entry
+ (files '("share/libretro/filters/video")))
+ (search-path-specification
+ (variable "LIBRETRO_VIDEO_SHADER_DIRECTORY")
+ (separator #f) ;single entry
+ (files '("share/libretro/shaders")))))
(home-page "https://www.libretro.com/")
(synopsis "Reference frontend for the libretro API")
(description