summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-12-24 17:07:02 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-12-24 17:07:02 +0100
commit6dc6d3950616ae3461755a35b37289e89fea0b9f (patch)
tree4a605881f61845595a570176667fef90055a1ab9 /gnu/packages/emacs-xyz.scm
parent70394f07dcd8b7adb38308822369e4ff54bc8faf (diff)
gnu: Add emacs-shell-maker.
* gnu/packages/emacs-xyz.scm (emacs-shell-maker): New variable. Change-Id: I67c9b342af8fa10b7178f8ef50fdf756c1adf4b2
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dd133ff16ca..b3662ae639b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9124,6 +9124,25 @@ same frame (in an extra window). You can customize the initial width of
the speedbar window.")
(license license:gpl3+))))
+(define-public emacs-shell-maker
+ (package
+ (name "emacs-shell-maker")
+ (version "0.74.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xenodium/shell-maker")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06prky3c8hfvbnb705qa436vznq05zjicdz870l7m2760h6803iz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/xenodium/shell-maker")
+ (synopsis "Create Emacs shells")
+ (description "Shell Maker is a convenience wrapper around Comint mode.")
+ (license license:gpl3+)))
+
(define-public emacs-shell-switcher
(package
(name "emacs-shell-switcher")