summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-12-24 13:05:08 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-12-24 14:34:41 +0100
commit000f3b6d5a54286dccc3b9b6f4315e75755f9693 (patch)
tree21a44de332997af9ef3ef41d4fe7752d1cb4ba01 /gnu/packages/emacs-xyz.scm
parentce7ed997db6b6e936968c043a49277d5a63fa526 (diff)
gnu: emacs-emacsql: Fix build.
* gnu/packages/emacs-xyz.scm (emacs-emacsql)[arguments]<#:test-command>: Fix test file names. <#:phases>: Do not build now removed sqlite custom backend. Change-Id: Ic9ed568f8d4e4994b7de0229205ab04b56c907fb
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm32
1 files changed, 4 insertions, 28 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0f393b2b697..8ed21bc5233 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24467,39 +24467,15 @@ object has been freed.")
#:test-command #~(list "emacs" "-Q" "--batch"
"-L" "tests"
"-L" "."
- "-l" "tests/emacsql-tests.el"
+ "-l" "tests/emacsql-compiler-tests.el"
+ "-l" "tests/emacsql-external-tests.el"
"-f" "ert-run-tests-batch-and-exit")
- #:modules '((guix build emacs-build-system)
- (guix build utils)
- (guix build emacs-utils)
- (srfi srfi-26))
#:phases
#~(modify-phases %standard-phases
(add-before 'install 'patch-elisp-shell-shebangs
(lambda _
(substitute* (find-files "." "\\.el")
- (("/bin/sh") (which "sh")))))
- (add-after 'patch-elisp-shell-shebangs 'setenv-shell
- (lambda _
- (setenv "SHELL" "sh")))
- (add-after 'setenv-shell 'build-emacsql-sqlite
- (lambda _
- (invoke "make" "binary" (string-append "CC=" #$(cc-for-target)))))
- (add-after 'build-emacsql-sqlite 'install-emacsql-sqlite
- ;; This build phase installs emacs-emacsql binary.
- (lambda _
- (install-file "sqlite/emacsql-sqlite"
- (string-append #$output "/bin"))))
- (add-after 'install-emacsql-sqlite 'patch-emacsql-sqlite.el
- ;; This build phase removes interactive prompts
- ;; and makes sure Emacs look for binaries in the right places.
- (lambda _
- (emacs-substitute-variables "emacsql-sqlite.el"
- ("emacsql-sqlite-executable"
- (string-append #$output "/bin/emacsql-sqlite"))
- ;; Make sure Emacs looks for ‘GCC’ binary in the right place.
- ("emacsql-sqlite-c-compilers"
- `(list ,(which "gcc")))))))))
+ (("/bin/sh") (which "sh"))))))))
(inputs
(list emacs-minimal `(,mariadb "dev") `(,mariadb "lib") postgresql))
(propagated-inputs
@@ -35875,7 +35851,7 @@ time.")
(rename-file f
(basename f)))
el-files)))))))
- (propagated-inputs (list emacs-request emacs-tp emacs-ts emacs-persist))
+ (propagated-inputs (list emacs-request emacs-tp emacs-persist))
(home-page "https://codeberg.org/martianh/mastodon.el")
(synopsis "Emacs client for Mastodon")
(description "@code{mastodon.el} is an Emacs client for Mastodon, the