summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2025-01-12 15:09:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:45 +0100
commitc0d4e4d9dc135b42e0e6757d26e516ee36478de6 (patch)
tree5f2c2c9cf31918cae2c531668d0f48c3a04e76dc /gnu/packages/django.scm
parent214e6e6232879ffde9f396e69cdfc256092a89d0 (diff)
gnu: python-django-debug-toolbar: Disable broken test.
* gnu/packages/django.scm (python-django-debug-toolbar)[build-system]: Use pyproject-build-system; disable one test. [native-inputs]: Add python-setuptools, python-wheel, and tzdata-for-tests. [description]: Complete sentence. Change-Id: Id6338302fd62c8a9244a8a5a429279d283467149
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm35
1 files changed, 23 insertions, 12 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index f6b687945d5..d924e9b2839 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -608,23 +608,34 @@ account authentication.")
(sha256
(base32
"1m1j2sx7q0blma0miswj3c8hrfi5q4y5cq2b816v8gagy89xgc57"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'disable-bad-tests
+ (lambda _
+ (substitute* "tests/test_integration.py"
+ (("def test_cache_page")
+ "def _test_cache_page"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "test")))))))
(propagated-inputs
(list python-sqlparse python-django))
(native-inputs
- (list python-django-jinja python-html5lib))
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "make" "test"))))))
- (home-page
- "https://github.com/jazzband/django-debug-toolbar")
+ (list python-django-jinja
+ python-html5lib
+ python-setuptools
+ python-wheel
+ tzdata-for-tests))
+ (home-page "https://github.com/jazzband/django-debug-toolbar")
(synopsis "Toolbar to help with developing Django applications")
(description
- "A configurable set of panels that display information about the current
-request and response as a toolbar on the rendered page.")
+ "This package provides a configurable set of panels that display
+information about the current request and response as a toolbar on the
+rendered page.")
(license license:bsd-3)))
(define-public python-django-debug-toolbar-alchemy