summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2024-02-22 20:47:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:25 +0000
commit6d97c15911a51d29f91e3656f9c4ab38e08d7f21 (patch)
treea42bcc8f38f2532ca0218d92323c993729912961 /gnu/packages/django.scm
parent1ef178c644178304b24bd29c7563ab0529c15f8f (diff)
gnu: Add python-setuptools/python-wheel where necessary.
Changes to pyproject-build-system require explicit dependency on setuptools/wheel. Change-Id: Icd7699fc1dc56e974ae7568f2ae916dbf876bea5
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 4cf043f7c13..c209a393844 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -191,7 +191,7 @@ to the @dfn{don't repeat yourself} (DRY) principle.")
"0dpx2wmcclmd3jkprdljz3makq12vd0sjv3xnvlj5vk1lg7glb7g"))))
(build-system pyproject-build-system)
(native-inputs
- (list python-django))
+ (list python-django python-setuptools python-wheel))
(home-page "https://github.com/epicserve/django-cache-url")
(synopsis "Configure Django cache settings from URLs")
(description
@@ -229,7 +229,9 @@ with a @var{CACHE_URL} environment variable.")
python-dj-email-url
python-dj-search-url
python-django-cache-url
- python-setuptools-scm))
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(home-page "https://django-configurations.readthedocs.io/")
(synopsis "Helper module for organizing Django settings")
(description
@@ -755,6 +757,7 @@ conn_max_age argument to easily enable Django’s connection pool.")
(base32
"16k91rvd9889xxrrf84a3zb0jpinizhfqdmafn54zxa8kqrf7zsm"))))
(build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://github.com/migonzalvar/dj-email-url")
(synopsis "Configure email settings from URLs")
(description
@@ -775,6 +778,7 @@ settings from URLs.")
(base32
"0h7vshhglym6af2pplkyivk6y0g0ncq0xpdzi88kq2sha9c1lka2"))))
(build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://github.com/dstufft/dj-search-url")
(synopsis "Configure Haystack search from URLs")
(description