summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-11 08:33:02 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:41 +0000
commitfdc0fefd46a45b70784a4e3f8900cbe593426a9e (patch)
tree13c3736334bde1c3ec75d67f4e430396e23eed3f /gnu/packages/databases.scm
parentca945f7c35bbc5d05a6ad7e5baa15f79e0fd0ecc (diff)
build-system/pyproject: Use python-sans-pip-wrapper as default-python.
Also adds python-setuptools and python-wheel to relevant packages, either to native-inputs or to propagated inputs if the pkg_resources Python module is loaded at runtime. * guix/build-system/pyproject.scm (default-python): Default to python-sans-pip-wrapper. Change-Id: I2d986c2225114f54459dd6bb360913106e52cdf4
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index dcd122cb224..b68f695513a 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3229,6 +3229,7 @@ protocol with Cython for performance.")
(build-system pyproject-build-system)
(arguments '(#:tests? #f)) ;test suite requires docker
(propagated-inputs (list python-pymysql))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://github.com/aio-libs/aiomysql")
(synopsis "MySQL driver for Python")
(description "@code{aiomysql} is a driver for accessing a MySQL database
@@ -3670,7 +3671,8 @@ on localhost.")
(build-system pyproject-build-system)
(native-inputs
(list python-cython ; for C extensions
- python-pytest python-mock python-pytest-xdist)) ; for tests
+ python-pytest python-mock python-pytest-xdist ; for tests
+ python-setuptools python-wheel))
(propagated-inputs
(list python-greenlet))
(arguments
@@ -3905,7 +3907,7 @@ text search extension.")
(propagated-inputs (list python-click python-click-default-group
python-dateutil python-sqlite-fts4
python-tabulate))
- (native-inputs (list python-pytest))
+ (native-inputs (list python-pytest python-setuptools python-wheel))
(home-page "https://github.com/simonw/sqlite-utils")
(synopsis
"CLI tool and Python utility functions for manipulating SQLite databases")
@@ -3978,7 +3980,7 @@ PickleShare.")
"10yfbasi4mq63g0svyl1h49ylwn9znjylq78id16dzxzk9q9ipdx"))))
(build-system pyproject-build-system)
(native-inputs
- (list unzip))
+ (list unzip python-setuptools python-wheel))
(inputs (list sqlite-next)) ;SQLite 3.45.1 required.
(arguments
(list
@@ -4333,7 +4335,7 @@ for Python. The design goals are:
;; The fix was forwarded upstream, see:
;; https://github.com/redis/hiredis-py/pull/160.
(delete-file "tests/__init__.py"))))))
- (native-inputs (list python-pytest))
+ (native-inputs (list python-pytest python-setuptools python-wheel))
(inputs (list hiredis))
(home-page "https://github.com/redis/hiredis-py")
(synopsis "Python extension that wraps protocol parsing code in hiredis")
@@ -4457,6 +4459,8 @@ reasonable substitute.")
python-pytest
python-pytest-asyncio
python-pytest-timeout
+ python-setuptools
+ python-wheel
redis))
(propagated-inputs
(list python-async-timeout))