summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-23 19:33:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:16:05 +0200
commita04e9eade31594b73f6b1f366e65dc517d77cac3 (patch)
tree50c189eea50712432f875707c8ba9c8176017ccc /gnu/packages/crates-web.scm
parent5aa2346d628ce30a53089169997779170ee2351d (diff)
gnu: Add rust-tungstenite-0.24.
* gnu/packages/crates-web.scm (rust-tungstenite-0.24): New variable. (rust-tungstenite-0.21): Inherit from rust-tungstenite-0.24. Change-Id: Ifceb2e4472769a5de9f1138ef9541de6dd2a2d0d
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm57
1 files changed, 46 insertions, 11 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index e833a0d3e5..f6ac4fbcaa 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -7470,8 +7470,53 @@ the Trust-DNS client to use rustls for TLS.")
(("rust-openssl" ,rust-openssl-0.10)
("rust-tokio" ,rust-tokio-0.1))))))
+(define-public rust-tungstenite-0.24
+ (package
+ (name "rust-tungstenite")
+ (version "0.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "tungstenite" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "12nsxnxazk4nisgsqpywi6za0hsbc2rd15r1scb5pag7dqvbir8q"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list #:cargo-inputs (list rust-byteorder-1
+ rust-bytes-1
+ rust-data-encoding-2
+ rust-http-1
+ rust-httparse-1
+ rust-log-0.4
+ rust-native-tls-0.2
+ rust-rand-0.8
+ rust-rustls-0.23
+ rust-rustls-native-certs-0.7
+ rust-rustls-pki-types-1
+ rust-sha1-0.10
+ rust-thiserror-1
+ rust-url-2
+ rust-utf-8-0.7
+ rust-webpki-roots-0.26)
+ #:cargo-development-inputs (list rust-criterion-0.5
+ rust-env-logger-0.10
+ rust-input-buffer-0.5
+ rust-rand-0.8
+ rust-socket2-0.5)))
+ (home-page "https://github.com/snapview/tungstenite-rs")
+ (synopsis "Lightweight stream-based WebSocket implementation")
+ (description
+ "This library provides an implementation of WebSockets, RFC6455. It
+allows for both synchronous (like TcpStream) and asynchronous usage and is
+easy to integrate into any third-party event loops including MIO. The API
+design abstracts away all the internals of the WebSocket protocol but still
+makes them accessible for those who wants full control over the network.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-tungstenite-0.21
(package
+ (inherit rust-tungstenite-0.24)
(name "rust-tungstenite")
(version "0.21.0")
(source
@@ -7481,7 +7526,6 @@ the Trust-DNS client to use rustls for TLS.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1qaphb5kgwgid19p64grhv2b9kxy7f1059yy92l9kwrlx90sdwcy"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
("rust-bytes" ,rust-bytes-1)
@@ -7503,16 +7547,7 @@ the Trust-DNS client to use rustls for TLS.")
("rust-env-logger" ,rust-env-logger-0.10)
("rust-input-buffer" ,rust-input-buffer-0.5)
("rust-rand" ,rust-rand-0.8)
- ("rust-socket2" ,rust-socket2-0.5))))
- (home-page "https://github.com/snapview/tungstenite-rs")
- (synopsis "Lightweight stream-based WebSocket implementation")
- (description
- "This library provides an implementation of WebSockets, RFC6455. It
-allows for both synchronous (like TcpStream) and asynchronous usage and is
-easy to integrate into any third-party event loops including MIO. The API
-design abstracts away all the internals of the WebSocket protocol but still
-makes them accessible for those who wants full control over the network.")
- (license (list license:expat license:asl2.0))))
+ ("rust-socket2" ,rust-socket2-0.5))))))
(define-public rust-tungstenite-0.20
(package