summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-26 21:39:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:19:34 +0200
commit8b8c54e76250b9d68021f6f33d94d6d324761a56 (patch)
tree033972ef61293fdb516af18889524a51f11242f6 /gnu/packages/crates-web.scm
parent18e8bf56294bb736fe2c6a6fa3acbfa04158c71e (diff)
gnu: rust-cookie: Move to (gnu packages crates-web).
* gnu/packages/crates-io.scm (rust-cookie-0.18, rust-cookie-0.17, rust-cookie-0.16, rust-cookie-0.15, rust-cookie-0.14, rust-cookie-0.12, rust-cookie-0.11, rust-cookie-factory-0.3, rust-cookie-store-0.21, rust-cookie-store-0.20, rust-cookie-store-0.19, rust-cookie-store-0.16, rust-cookie-store-0.15, rust-cookie-store-0.12): Move from here ... * gnu/packages/crates-web.scm: ... to here. Change-Id: I92fc2abfede54fc1c6f8f46ba23b27ef79fef4a6
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm358
1 files changed, 358 insertions, 0 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index edc13a8840..af1fc1527e 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -2632,6 +2632,364 @@ transfer coding.")
(base32 "11yghnd24w0i9p8g368c3pg7qh9nfz7kgri6pywja9pnmakj13a9"))))
(arguments `())))
+(define-public rust-cookie-0.18
+ (package
+ (name "rust-cookie")
+ (version "0.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cookie" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1y2ywf9isq0dwpj7m7jq7r1g9cs3xr2i6qipw5v030hj2kv1rn9w"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-aes-gcm" ,rust-aes-gcm-0.10)
+ ("rust-base64" ,rust-base64-0.21)
+ ("rust-hkdf" ,rust-hkdf-0.12)
+ ("rust-hmac" ,rust-hmac-0.12)
+ ("rust-percent-encoding" ,rust-percent-encoding-2)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-sha2" ,rust-sha2-0.10)
+ ("rust-subtle" ,rust-subtle-2)
+ ("rust-time" ,rust-time-0.3)
+ ("rust-version-check" ,rust-version-check-0.9))))
+ (home-page "https://github.com/SergioBenitez/cookie-rs")
+ (synopsis
+ "Crate for parsing HTTP cookie headers and managing a cookie jar")
+ (description
+ "Parse HTTP cookie headers and manage a cookie jar with this crate.
+It supports signed and private (encrypted + signed) jars.")
+ ;; The user can choose either license.
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-cookie-0.17
+ (package
+ (inherit rust-cookie-0.18)
+ (name "rust-cookie")
+ (version "0.17.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "cookie" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "096c52jg9iq4lfcps2psncswv33fc30mmnaa2sbzzcfcw71kgyvy"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-aes-gcm" ,rust-aes-gcm-0.10)
+ ("rust-base64" ,rust-base64-0.21)
+ ("rust-hkdf" ,rust-hkdf-0.12)
+ ("rust-hmac" ,rust-hmac-0.12)
+ ("rust-percent-encoding" ,rust-percent-encoding-2)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-sha2" ,rust-sha2-0.10)
+ ("rust-subtle" ,rust-subtle-2)
+ ("rust-time" ,rust-time-0.3)
+ ("rust-version-check" ,rust-version-check-0.9))))))
+
+(define-public rust-cookie-0.16
+ (package
+ (inherit rust-cookie-0.17)
+ (name "rust-cookie")
+ (version "0.16.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cookie" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1yriqbf77iigrnp2gmf6m1r296bndv051dc1qc39w3bis1bwsng8"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-aes-gcm" ,rust-aes-gcm-0.10)
+ ("rust-base64" ,rust-base64-0.20)
+ ("rust-hkdf" ,rust-hkdf-0.12)
+ ("rust-hmac" ,rust-hmac-0.12)
+ ("rust-percent-encoding" ,rust-percent-encoding-2)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-sha2" ,rust-sha2-0.10)
+ ("rust-subtle" ,rust-subtle-2)
+ ("rust-time" ,rust-time-0.3)
+ ("rust-version-check" ,rust-version-check-0.9))))))
+
+(define-public rust-cookie-0.15
+ (package
+ (inherit rust-cookie-0.16)
+ (name "rust-cookie")
+ (version "0.15.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cookie" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0hlsi1hv5yrx4g92v5acha6yjz8dy1zj0pbppwynml44qpgjavpw"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-aes-gcm" ,rust-aes-gcm-0.8)
+ ("rust-base64" ,rust-base64-0.13)
+ ("rust-hkdf" ,rust-hkdf-0.10)
+ ("rust-hmac" ,rust-hmac-0.10)
+ ("rust-percent-encoding" ,rust-percent-encoding-2)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-sha2" ,rust-sha2-0.9)
+ ("rust-subtle" ,rust-subtle-2)
+ ("rust-time" ,rust-time-0.2)
+ ("rust-version-check" ,rust-version-check-0.9))))))
+
+(define-public rust-cookie-0.14
+ (package
+ (inherit rust-cookie-0.15)
+ (name "rust-cookie")
+ (version "0.14.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cookie" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ldryjb41r8n0ar2pya0bajlxr8s4j59fjkmyi5ppg1932rdg983"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-aes-gcm" ,rust-aes-gcm-0.8)
+ ("rust-base64" ,rust-base64-0.13)
+ ("rust-hkdf" ,rust-hkdf-0.10)
+ ("rust-hmac" ,rust-hmac-0.10)
+ ("rust-percent-encoding" ,rust-percent-encoding-2)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-sha2" ,rust-sha2-0.9)
+ ("rust-time" ,rust-time-0.2)
+ ("rust-version-check" ,rust-version-check-0.9))))))
+
+(define-public rust-cookie-0.12
+ (package
+ (inherit rust-cookie-0.15)
+ (name "rust-cookie")
+ (version "0.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cookie" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1mdvqixahcywvqp0y8k2skkgbpfhsp0w73l9mz93dcrx1gq091l8"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-base64" ,rust-base64-0.10)
+ ("rust-ring" ,rust-ring-0.14)
+ ("rust-time" ,rust-time-0.1)
+ ("rust-url" ,rust-url-1))))))
+
+(define-public rust-cookie-0.11
+ (package
+ (inherit rust-cookie-0.12)
+ (name "rust-cookie")
+ (version "0.11.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cookie" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1mwbcygk9als9h7bfp8fhax2ah278qamaz9l9p64in6iirv1h85y"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-aes-gcm" ,rust-aes-gcm-0.8)
+ ("rust-base64" ,rust-base64-0.13)
+ ("rust-hkdf" ,rust-hkdf-0.10)
+ ("rust-hmac" ,rust-hmac-0.10)
+ ("rust-percent-encoding" ,rust-percent-encoding-2)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-sha2" ,rust-sha2-0.9)
+ ("rust-time" ,rust-time-0.1))))))
+
+(define-public rust-cookie-factory-0.3
+ (package
+ (name "rust-cookie-factory")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cookie-factory" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0sqjmw85ckqhppff6gjwmvjpkii35441a51xx7cv0ih3jy2fjv9r"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f
+ #:cargo-development-inputs (("rust-maplit" ,rust-maplit-1))))
+ (home-page "https://github.com/rust-bakery/cookie-factory")
+ (synopsis "Combinator-based serialization library")
+ (description
+ "This package provides a serialization library with a combinator design
+similar to the nom parser combinators library.")
+ (license license:expat)))
+
+(define-public rust-cookie-store-0.21
+ (package
+ (name "rust-cookie-store")
+ (version "0.21.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cookie_store" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1y9ydb52bcd1zc7r0mppy8c8l541p459a006xr0m52pq50c91b1f"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list #:cargo-inputs
+ (list rust-cookie-0.18
+ rust-document-features-0.2
+ rust-idna-1
+ rust-indexmap-2
+ rust-log-0.4
+ rust-publicsuffix-2
+ rust-ron-0.8
+ rust-serde-1
+ rust-serde-derive-1
+ rust-serde-json-1
+ rust-time-0.3
+ rust-url-2)))
+ (home-page "https://github.com/pfernie/cookie_store")
+ (synopsis "Cookie storage and retrieval")
+ (description "This package implements cookie storage and retrieval.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-cookie-store-0.20
+ (package
+ (inherit rust-cookie-store-0.21)
+ (name "rust-cookie-store")
+ (version "0.20.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cookie_store" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1xkc7fl1jik9ki13j9pjgyw51d0qd613srz1lv1qb0blpjmn2x1q"))))
+ (arguments
+ `(#:cargo-inputs (("rust-cookie" ,rust-cookie-0.17)
+ ("rust-idna" ,rust-idna-0.3)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-publicsuffix" ,rust-publicsuffix-2)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-time" ,rust-time-0.3)
+ ("rust-url" ,rust-url-2))))))
+
+(define-public rust-cookie-store-0.19
+ (package
+ (inherit rust-cookie-store-0.20)
+ (name "rust-cookie-store")
+ (version "0.19.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "cookie_store" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "19vy19rvp3a68sgxkrv6bxxlrr2ggqp0176yqb3zhmi0g4sqz8fm"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-cookie" ,rust-cookie-0.16)
+ ("rust-idna" ,rust-idna-0.3)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-publicsuffix" ,rust-publicsuffix-2)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-time" ,rust-time-0.3)
+ ("rust-url" ,rust-url-2))))))
+
+(define-public rust-cookie-store-0.16
+ (package
+ (inherit rust-cookie-store-0.19)
+ (name "rust-cookie-store")
+ (version "0.16.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cookie_store" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1kfrmxx9mi55dgbj8qgd8qbahvi1yjqwk05v0jm5y7zld6inljrf"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-cookie" ,rust-cookie-0.16)
+ ("rust-idna" ,rust-idna-0.2)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-publicsuffix" ,rust-publicsuffix-2)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-time" ,rust-time-0.3)
+ ("rust-url" ,rust-url-2))))))
+
+(define-public rust-cookie-store-0.15
+ (package
+ (inherit rust-cookie-store-0.16)
+ (name "rust-cookie-store")
+ (version "0.15.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cookie_store" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0z0navy9k0ivrdvz492q8c4nhd3iv5l77hwfppskdp1j15607xxk"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-cookie" ,rust-cookie-0.15)
+ ("rust-idna" ,rust-idna-0.2)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-publicsuffix" ,rust-publicsuffix-2)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-time" ,rust-time-0.2)
+ ("rust-url" ,rust-url-2))))))
+
+(define-public rust-cookie-store-0.12
+ (package
+ (inherit rust-cookie-store-0.15)
+ (name "rust-cookie-store")
+ (version "0.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cookie_store" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lqhmdwgnyvi1mjmw4rbgd02fwav4aabpg4vcld23d8c9g5dy61q"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-cookie" ,rust-cookie-0.14)
+ ("rust-idna" ,rust-idna-0.2)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-publicsuffix" ,rust-publicsuffix-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-time" ,rust-time-0.2)
+ ("rust-url" ,rust-url-2))
+ #:cargo-development-inputs
+ (("rust-env-logger" ,rust-env-logger-0.7)
+ ("rust-pretty-assertions" ,rust-pretty-assertions-0.6))))))
+
(define-public rust-gemini-fetch-0.2
(package
(name "rust-gemini-fetch")