summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-12-24 11:31:07 +0100
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:16:26 +0200
commit3c4cb9b071b4833c27ae092c712a11f49ce7ebae (patch)
tree4494f79b2aeb0f426033500ebff07452c7ff2121 /gnu/packages/crates-web.scm
parentac3f741499db932a36335e36358d0dfd88ff317d (diff)
gnu: rust-hyperlocal-0.8: Order alphabetically.
* gnu/packages/crates-web.scm (rust-hyperlocal-0.8): Order. Change-Id: I128a5ef1284e5cb83741f3ee4ea3516dee9f67d3 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index a0e0bd7192..d85bbd1929 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -4101,31 +4101,6 @@ dependencies.")
("rust-unicase" ,rust-unicase-1)
("rust-url" ,rust-url-1))))))
-(define-public rust-hyperlocal-0.8
- (package
- (name "rust-hyperlocal")
- (version "0.8.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "hyperlocal" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "136978rsp0wr6x28cxivxhbq2np66l4jrq3n9xwckrrd5dxxzbqg"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs (("rust-futures-util" ,rust-futures-util-0.3)
- ("rust-hex" ,rust-hex-0.4)
- ("rust-hyper" ,rust-hyper-0.14)
- ("rust-pin-project" ,rust-pin-project-1)
- ("rust-tokio" ,rust-tokio-1))
- #:cargo-development-inputs (("rust-tokio" ,rust-tokio-1))))
- (home-page "https://github.com/softprops/hyperlocal")
- (synopsis "Hyper bindings for Unix domain sockets")
- (description
- "This package provides Hyper bindings for Unix domain sockets.")
- (license license:expat)))
-
(define-public rust-hyper-native-tls-0.3
(package
(name "rust-hyper-native-tls")
@@ -4563,6 +4538,31 @@ with hyper.")
(description "This package provides utilities for the @code{hyper} crate.")
(license license:expat)))
+(define-public rust-hyperlocal-0.8
+ (package
+ (name "rust-hyperlocal")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hyperlocal" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "136978rsp0wr6x28cxivxhbq2np66l4jrq3n9xwckrrd5dxxzbqg"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-hex" ,rust-hex-0.4)
+ ("rust-hyper" ,rust-hyper-0.14)
+ ("rust-pin-project" ,rust-pin-project-1)
+ ("rust-tokio" ,rust-tokio-1))
+ #:cargo-development-inputs (("rust-tokio" ,rust-tokio-1))))
+ (home-page "https://github.com/softprops/hyperlocal")
+ (synopsis "Hyper bindings for Unix domain sockets")
+ (description
+ "This package provides Hyper bindings for Unix domain sockets.")
+ (license license:expat)))
+
(define-public rust-iron-0.6
(package
(name "rust-iron")