summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-12-24 11:31:05 +0100
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:16:26 +0200
commit1547530990feac6a9128ad2369f90529ed508a8f (patch)
tree8d3a58c0090a831eb5c81d9ffeb8eaee44888539 /gnu/packages/crates-web.scm
parentbcb131088b56759adfa2f37341943df96c9fa2f5 (diff)
gnu: rust-actix-test-server-0.2: Order alphabetically.
* gnu/packages/crates-web.scm (rust-actix-test-server-0.2): Order. Change-Id: If49f08b0145e6809fa86059b1775f387792935fc Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm70
1 files changed, 35 insertions, 35 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 3860c0945b..adafc1bbb7 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -1251,6 +1251,41 @@ asynchronous request/response operations.")
"This package provides integration testing tools for Actix Web applications.")
(license (list license:expat license:asl2.0))))
+(define-public rust-actix-test-server-0.2
+ (package
+ (name "rust-actix-test-server")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "actix-test-server" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0lqx8adsl3nlhbnvvjrmy9mkfa0d8wmwyy4gdz5ik8xhbwibxnn2"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-actix-rt" ,rust-actix-rt-0.2)
+ ("rust-actix-server" ,rust-actix-server-0.5)
+ ("rust-actix-server-config" ,rust-actix-server-config-0.1)
+ ("rust-futures" ,rust-futures-0.1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-native-tls" ,rust-native-tls-0.2)
+ ("rust-net2" ,rust-net2-0.2)
+ ("rust-openssl" ,rust-openssl-0.10)
+ ("rust-rustls" ,rust-rustls-0.15)
+ ("rust-tokio-reactor" ,rust-tokio-reactor-0.1)
+ ("rust-tokio-rustls" ,rust-tokio-rustls-0.9)
+ ("rust-tokio-tcp" ,rust-tokio-tcp-0.1)
+ ("rust-webpki" ,rust-webpki-0.19)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.16))
+ #:cargo-development-inputs
+ (("rust-actix-service" ,rust-actix-service-0.4))))
+ (home-page "https://actix.rs")
+ (synopsis "Actix test server")
+ (description "Actix test server.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-actix-testing-1
(package
(name "rust-actix-testing")
@@ -1301,41 +1336,6 @@ asynchronous request/response operations.")
("rust-tokio-reactor" ,rust-tokio-reactor-0.1)
("rust-tokio-tcp" ,rust-tokio-tcp-0.1))))))
-(define-public rust-actix-test-server-0.2
- (package
- (name "rust-actix-test-server")
- (version "0.2.2")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "actix-test-server" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0lqx8adsl3nlhbnvvjrmy9mkfa0d8wmwyy4gdz5ik8xhbwibxnn2"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-actix-rt" ,rust-actix-rt-0.2)
- ("rust-actix-server" ,rust-actix-server-0.5)
- ("rust-actix-server-config" ,rust-actix-server-config-0.1)
- ("rust-futures" ,rust-futures-0.1)
- ("rust-log" ,rust-log-0.4)
- ("rust-native-tls" ,rust-native-tls-0.2)
- ("rust-net2" ,rust-net2-0.2)
- ("rust-openssl" ,rust-openssl-0.10)
- ("rust-rustls" ,rust-rustls-0.15)
- ("rust-tokio-reactor" ,rust-tokio-reactor-0.1)
- ("rust-tokio-rustls" ,rust-tokio-rustls-0.9)
- ("rust-tokio-tcp" ,rust-tokio-tcp-0.1)
- ("rust-webpki" ,rust-webpki-0.19)
- ("rust-webpki-roots" ,rust-webpki-roots-0.16))
- #:cargo-development-inputs
- (("rust-actix-service" ,rust-actix-service-0.4))))
- (home-page "https://actix.rs")
- (synopsis "Actix test server")
- (description "Actix test server.")
- (license (list license:expat license:asl2.0))))
-
(define-public rust-actix-threadpool-0.3
(package
(name "rust-actix-threadpool")