summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-audio.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-26 18:45:15 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:19:26 +0200
commit44825fea342c503459c1b2e3f7963659d2f825c3 (patch)
treec84df04f6e398abfbffd616d6684e7b58df2a67f /gnu/packages/crates-audio.scm
parentf17c7b3ab628a66f7ecc25753e5764273e8c156d (diff)
gnu: rust-lv2: Move to (gnu packages crates-audio).
* gnu/packages/crates-io.scm (rust-lv2-0.6, rust-lv2-atom-2, rust-lv2-core-3, rust-lv2-core-derive-2, rust-lv2-midi-1, rust-lv2-state-2. rust-lv2-sys-2, rust-lv2-time-0.1, rust-lv2-units-0.1, rust-lv2-urid-2, rust-lv2-worker-0.1): Move from here ... * gnu/packages/crates-audio.scm: ... to here. * gnu/local.mk (GNU_SYSTEM_MODULES): Register new file. Change-Id: Ifa9fa397290735dd4c9c6ed3e2004baafc472416
Diffstat (limited to 'gnu/packages/crates-audio.scm')
-rw-r--r--gnu/packages/crates-audio.scm278
1 files changed, 278 insertions, 0 deletions
diff --git a/gnu/packages/crates-audio.scm b/gnu/packages/crates-audio.scm
new file mode 100644
index 0000000000..819ef63284
--- /dev/null
+++ b/gnu/packages/crates-audio.scm
@@ -0,0 +1,278 @@
+;;; Copyright © 2024 Roman Scherer <roman@burningswell.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages crates-audio)
+ #:use-module (guix build-system cargo)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages crates-io))
+
+;;;
+;;; Please: Try to add new module packages in alphabetic order.
+;;;
+
+(define-public rust-lv2-0.6
+ (package
+ (name "rust-lv2")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lv2" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1xh4hjfh2w5rhzbk0g9845k25f6fxrv7xqpkr09p0x57b200qc41"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-lv2-atom" ,rust-lv2-atom-2)
+ ("rust-lv2-core" ,rust-lv2-core-3)
+ ("rust-lv2-midi" ,rust-lv2-midi-1)
+ ("rust-lv2-state" ,rust-lv2-state-2)
+ ("rust-lv2-sys" ,rust-lv2-sys-2)
+ ("rust-lv2-time" ,rust-lv2-time-0.1)
+ ("rust-lv2-units" ,rust-lv2-units-0.1)
+ ("rust-lv2-urid" ,rust-lv2-urid-2)
+ ("rust-lv2-worker" ,rust-lv2-worker-0.1)
+ ("rust-urid" ,rust-urid-0.1))))
+ (home-page "https://github.com/RustAudio/rust-lv2")
+ (synopsis "Safe, fast, and ergonomic framework to create LV2 plugins in Rust")
+ (description "This package provides a safe, fast, and ergonomic framework
+to create LV2 plugins in Rust.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-lv2-atom-2
+ (package
+ (name "rust-lv2-atom")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lv2-atom" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0wd9rgsn8sag8wyhjccmnn82gx4w1yyiav52nyvk579l21xlw6wm"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-lv2-core" ,rust-lv2-core-3)
+ ("rust-lv2-sys" ,rust-lv2-sys-2)
+ ("rust-lv2-units" ,rust-lv2-units-0.1)
+ ("rust-urid" ,rust-urid-0.1))
+ #:cargo-development-inputs (("rust-lv2-urid" ,rust-lv2-urid-2))))
+ (home-page "https://github.com/RustAudio/rust-lv2")
+ (synopsis "Rust LV2 Atom handling library")
+ (description "This package provides a Rust LV2 Atom handling library.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-lv2-core-3
+ (package
+ (name "rust-lv2-core")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lv2-core" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1pj9l15zwqwj2h83f3xfpwxsj70vvhkw52gyzkljafvrbx1h00fm"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-lv2-core-derive" ,rust-lv2-core-derive-2)
+ ("rust-lv2-sys" ,rust-lv2-sys-2)
+ ("rust-urid" ,rust-urid-0.1))))
+ (home-page "https://github.com/RustAudio/rust-lv2")
+ (synopsis "Rust LV2 core library")
+ (description "This package provides the Rust LV2 core library.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-lv2-core-derive-2
+ (package
+ (name "rust-lv2-core-derive")
+ (version "2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lv2-core-derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "12w3l41jzargrcywz13hbmaazfw4ix2sljl3601h6jfbdrw8zybv"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))))
+ (home-page "https://github.com/RustAudio/rust-lv2")
+ (synopsis "Procedural macros for lv2-core")
+ (description "This package provides Procedural macros for lv2-core.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-lv2-midi-1
+ (package
+ (name "rust-lv2-midi")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lv2-midi" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0x0glbrfri1glgcrmvc6i1jfv6azhpqvp4ibk5cihsq3s2yfc8xd"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; use of undeclared crate or module `wmidi`
+ #:cargo-inputs (("rust-lv2-atom" ,rust-lv2-atom-2)
+ ("rust-lv2-sys" ,rust-lv2-sys-2)
+ ("rust-urid" ,rust-urid-0.1)
+ ("rust-wmidi" ,rust-wmidi-3))
+ #:cargo-development-inputs (("rust-lv2-core" ,rust-lv2-core-3)
+ ("rust-lv2-units" ,rust-lv2-units-0.1))))
+ (home-page "https://github.com/RustAudio/rust-lv2")
+ (synopsis "Rust LV2 MIDI processing library")
+ (description "This package provides a Rust LV2 MIDI processing library.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-lv2-state-2
+ (package
+ (name "rust-lv2-state")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lv2-state" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0nm0fc7cb4rkmfsvvr4xbac4qf0j7wl2gws3qrcflx057i2lpsb5"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-lv2-atom" ,rust-lv2-atom-2)
+ ("rust-lv2-core" ,rust-lv2-core-3)
+ ("rust-lv2-sys" ,rust-lv2-sys-2)
+ ("rust-urid" ,rust-urid-0.1))
+ #:cargo-development-inputs (("rust-lv2-urid" ,rust-lv2-urid-2)
+ ("rust-mktemp" ,rust-mktemp-0.4))))
+ (home-page "https://github.com/RustAudio/rust-lv2")
+ (synopsis "Rust LV2 state handling library")
+ (description "This package provides a Rust LV2 state handling library.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-lv2-sys-2
+ (package
+ (name "rust-lv2-sys")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lv2-sys" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0c4f59mrjyy0z0wf033wp648df0sc6zirrcd6kndqj9nvvkzkl4x"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/RustAudio/rust-lv2")
+ (synopsis "Rust LV2 C header bindings")
+ (description "This package provides Rust LV2 C header bindings.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-lv2-time-0.1
+ (package
+ (name "rust-lv2-time")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lv2-time" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0wznk17vvn5dph6r47vjwmf7g98pb6ij2fdhizdk95sf2qvkf82c"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-lv2-sys" ,rust-lv2-sys-2)
+ ("rust-urid" ,rust-urid-0.1))))
+ (home-page "https://github.com/RustAudio/rust-lv2")
+ (synopsis "Rust LV2 wrapper for LV2 time types")
+ (description "This package provides a Rust LV2 wrapper for LV2 time types.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-lv2-units-0.1
+ (package
+ (name "rust-lv2-units")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lv2-units" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0fdamp3hxdr36hqi1j6y01rz1x17if1ibzr7rr4nrabidw74gf82"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-lv2-sys" ,rust-lv2-sys-2)
+ ("rust-urid" ,rust-urid-0.1))))
+ (home-page "https://github.com/RustAudio/rust-lv2")
+ (synopsis "Rust LV2 wrapper of LV2 unit types")
+ (description "This package provides a Rust LV2 wrapper of LV2 unit types.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-lv2-urid-2
+ (package
+ (name "rust-lv2-urid")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lv2-urid" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0s2fcb0nyn54ml6azkbhnnxghy898x1q5vs5qgdznrhy9m20624c"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-lv2-core" ,rust-lv2-core-3)
+ ("rust-lv2-sys" ,rust-lv2-sys-2)
+ ("rust-urid" ,rust-urid-0.1))))
+ (home-page "https://github.com/RustAudio/rust-lv2")
+ (synopsis "Rust LV2 URID handling library")
+ (description "This package provides a LV2 URID handling library.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-lv2-worker-0.1
+ (package
+ (name "rust-lv2-worker")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lv2-worker" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "14crsrnjyarra9ipma6lhaj4gpfadvippzr134nkn0z3y30ip4fj"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; Tests panic
+ #:cargo-inputs (("rust-lv2-core" ,rust-lv2-core-3)
+ ("rust-lv2-sys" ,rust-lv2-sys-2)
+ ("rust-urid" ,rust-urid-0.1))))
+ (home-page "https://github.com/RustAudio/rust-lv2")
+ (synopsis "Rust LV2 work offloading library")
+ (description "This package provides a Rust LV2 work offloading library.")
+ (license (list license:expat license:asl2.0))))
+
+;;;
+;;; Avoid adding new packages to the end of this file. To reduce the chances
+;;; of a merge conflict, place them above by existing packages with similar
+;;; functionality or similar names.
+;;;