summaryrefslogtreecommitdiff
path: root/gnu/packages/containers.scm
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundation.xyz>2024-07-04 12:11:58 +0200
committerLudovic Courtès <ludo@gnu.org>2024-07-20 12:13:20 +0200
commit1fa4d658d808202f98003d1488f8e44daee370a9 (patch)
tree381d04fee33f391e26274db8fc3e5fff6ec1894d /gnu/packages/containers.scm
parentd1d70d25c84f1fe2d1998822125a83709c0685ef (diff)
gnu: distrobox: Patch distrobox-generate-entry.
Avoids keeping store references in generated desktop files. * gnu/packages/containers.scm (distrobox)<arguments>: add 'patch-distrobox-generate-entry phase. Change-Id: Ib1bffaefa1805accb5227c289c9fc985853bc675 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/containers.scm')
-rw-r--r--gnu/packages/containers.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 991a05f43c..a80596aa53 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -174,6 +174,14 @@ runtime (like runc or crun) for a single container.")
(arguments
(list #:phases
#~(modify-phases %standard-phases
+ ;; This script creates desktop files but when the store path for
+ ;; distrobox changes it leaves the stale path on the desktop
+ ;; file, so remove the path to use the profile's current
+ ;; distrobox.
+ (add-after 'unpack 'patch-distrobox-generate-entry
+ (lambda _
+ (substitute* "distrobox-generate-entry"
+ (("\\$\\{distrobox_path\\}/distrobox") "distrobox"))))
;; Use WRAP-SCRIPT to wrap all of the scripts of distrobox,
;; excluding the host side ones.
(add-after 'install 'wrap-scripts