summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-23 13:14:25 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:31 +0000
commitde3a139b3c74952e527933400600db251cffbe03 (patch)
treef77ce601f088b9b4a92abee09b2781ea2d6324af /gnu/packages/check.scm
parentbefea34619b05f2322a485dc10576005e3c8eb28 (diff)
gnu: python-pytest-regressions: Update to 2.5.0.
* gnu/packages/check.scm (python-pytest-regressions): Update to 2.5.0. [build-system]: Swap to pyproject-build-system. [native-inputs]: Remove python-tox; add python-setuptools. [description]: Adjust fill collumn. Change-Id: If571fae93dfbdf8543633f57fe5e597e1667ab25
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index dc5c0a8830..e22d436c79 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -4188,32 +4188,33 @@ directories and files.")
(define-public python-pytest-regressions
(package
(name "python-pytest-regressions")
- (version "2.3.1")
+ (version "2.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-regressions" version))
(sha256
- (base32
- "0792s1rp4hksfarnnciy0yiy2q2yqqsbin3mc9h2gxp86kdlrv5k"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python-pytest-datadir python-pyyaml))
+ (base32 "1nbg20m83jsj9p12fm4qn5b7hc3vqb5h5fzfi6zvmwygq627i341"))))
+ (build-system pyproject-build-system)
(native-inputs
(list python-matplotlib
python-numpy
python-pandas
python-pillow
python-restructuredtext-lint
- python-tox
+ python-setuptools
python-setuptools-scm
python-pytest))
+ (propagated-inputs
+ (list python-pytest-datadir
+ python-pyyaml))
(home-page "https://github.com/ESSS/pytest-regressions")
(synopsis "Easy to use fixtures to write regression tests")
(description
- "This plugin makes it simple to test general data, images, files, and numeric
-tables by saving expected data in a data directory (courtesy of pytest-datadir)
-that can be used to verify that future runs produce the same data.")
+ "This plugin makes it simple to test general data, images, files, and
+numeric tables by saving expected data in a data directory (courtesy of
+pytest-datadir) that can be used to verify that future runs produce the same
+data.")
(license license:expat)))
(define-public python-pytest-tornado5