summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-22 11:07:34 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:27 +0000
commit7fd0b73989e5f30b96798f5778cf265aae5bb579 (patch)
tree42790fae5848c06ceada406da572cd63940cd6f5 /gnu/packages/check.scm
parent809d36e2e22bfdfab73d2859b9fbf6224e977bd3 (diff)
gnu: python-pytest-asyncio: Update to 0.24.0.
* gnu/packages/check.scm (python-pytest-asyncio): Update to 0.24.0. [source]: Swap to PyPI tarball as a fresh release contains tests. [arguments]<tests>: Enable them. <phases>: Remove 'pretend-version phase. Change-Id: I67f11641fba485a94f5617292a4d75ec25af8420
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm27
1 files changed, 10 insertions, 17 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index ac08830fd5..83996f5e6b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2471,27 +2471,20 @@ executed.")
(define-public python-pytest-asyncio
(package
(name "python-pytest-asyncio")
- (version "0.21.0")
+ (version "0.24.0")
(source
(origin
- (method git-fetch) ;for tests
- (uri (git-reference
- (url "https://github.com/pytest-dev/pytest-asyncio")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (pypi-uri "pytest_asyncio" version))
(sha256
- (base32 "03wljn0gdwyfr5s1795w3h2mfvvi23bn42nwjv5568rgphqyldqq"))))
+ (base32 "0xmj8rndpv9gmwpilbfpc26sdy1bx60l46craf3mzn3nwlldi0fh"))))
(build-system pyproject-build-system)
- (arguments
- (list #:tests? #f ;XXX: to avoid a cycle with python-pytest-trio
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'pretend-version
- (lambda _
- (setenv "SETUPTOOLS_SCM_PRETEND_VERSION"
- #$(package-version this-package)))))))
- (native-inputs (list python-setuptools-scm python-setuptools python-wheel))
- (propagated-inputs (list python-pytest))
+ (native-inputs
+ (list python-setuptools-scm
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-pytest))
(home-page "https://github.com/pytest-dev/pytest-asyncio")
(synopsis "Pytest support for asyncio")
(description "Python asyncio code is usually written in the form of