summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorAshvith Shetty <ashvithshetty10@gmail.com>2024-12-31 23:39:47 +0530
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2025-01-06 18:49:49 +0800
commit359cb222f545985cb87fb2779b2535d37942ae75 (patch)
tree692b807addd4a3a1a92170f4f38f5ee002148f5f /gnu/packages/check.scm
parentef1c8ca7622b1441d2a8db97a9d0f1607275bdbe (diff)
gnu: Add trompeloeil.
* gnu/packages/check.scm (trompeloeil): New variable. Change-Id: I442cd0b5e84e8f9956b16b7d9235f67d9f5f693e Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index b5c05e36c93..e28564c0b02 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -52,6 +52,7 @@
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2024 Ashvith Shetty <ashvithshetty10@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3806,6 +3807,39 @@ accept @emph{valid} tests and output precisely what is expected pass the
tests. The output format is JSON.")
(license license:expat)))
+(define-public trompeloeil
+ (package
+ (name "trompeloeil")
+ (version "49")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rollbear/trompeloeil")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0m4bfzcj033qfk3sihbikrhk9krsdbsqk79nsambnsnqqcgc2903"))))
+ (build-system cmake-build-system)
+ (arguments
+ (append
+ (if (%current-target-system)
+ (list)
+ (list #:configure-flags #~(list "-DTROMPELOEIL_BUILD_TESTS=yes")))
+ (list
+ #:test-target "test/self_test"
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? test-target #:allow-other-keys)
+ (when tests?
+ (invoke test-target))))))))
+ (native-inputs (list catch2-3))
+ (home-page "https://github.com/rollbear/trompeloeil")
+ (synopsis "Header only C++14 mocking framework")
+ (description
+ "Trompeloeil is a thread-safe header-only mocking framework for C++11/14.")
+ (license license:boost1.0)))
+
(define-public unittest-cpp
(package
(name "unittest-cpp")