summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-22 13:19:29 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:28 +0000
commit1305fc004a7d150f3dc6647343d9d8f0d3bc4652 (patch)
tree4da844a98c645fa8aa374570fa72754033a54df1 /gnu/packages/check.scm
parentc5a45b3a8fe3887c853dc30af0ead6c47cc139de (diff)
gnu: Add python-pytest-lazy-fixtures.
* gnu/packages/check.scm (python-pytest-lazy-fixtures): New variable. Change-Id: I366ede16bf72f99b38b1edc43535a2c969822787
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 13aabb577cd..42a1957de3d 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2002,6 +2002,29 @@ Python's @code{random.seed}.")
@code{pytest.mark.parametrize}.")
(license license:expat)))
+(define-public python-pytest-lazy-fixtures
+ (package
+ (name "python-pytest-lazy-fixtures")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest_lazy_fixtures" version))
+ (sha256
+ (base32 "1v819n9jrgf0rk2fidn6fkdzz68r4jin94lvy9fbb9gf546iymhc"))))
+ (native-inputs
+ (list python-poetry-core))
+ (propagated-inputs
+ (list python-pytest))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/dev-petrov/pytest-lazy-fixtures")
+ (synopsis "Use fixtures in @code{pytest.mark.parametrize}")
+ (description
+ "This plugin helps to use fixtures in @code{pytest.mark.parametrize},
+inspied by @url{https://github.com/TvoroG/pytest-lazy-fixture,
+pytest-lazy-fixture}.")
+ (license license:expat)))
+
(define-public python-pytest-mock
(package
(name "python-pytest-mock")