summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-17 21:45:21 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:26 +0000
commit045fcc78ca44ceb3e5f07a95156842bb2f965a23 (patch)
treedbfcf24c5ea0a3ed3075d7d4f2dc096c80f2b4d6 /gnu/packages/check.scm
parent92c4bedf07393cbf30e5c5214d781105af5c8150 (diff)
gnu: python-pytest-httpserver: Update to 1.1.0.
* gnu/packages/check.scm (python-pytest-httpserver): Update to 1.1.0. Adjust indentation. [build-system]: Swap to pyproject-build-system. [arguments]<phases>: Remove 'fix-library-loading phase, and use default 'check phase. [native-inputs]: Add python-poetry-core and python-toml. Change-Id: Id0857d4042a3edfb676a46b8c20d051aa4cb1f93
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm35
1 files changed, 14 insertions, 21 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index e9501df85f2..ac08830fd58 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1797,32 +1797,25 @@ update print statements
(define-public python-pytest-httpserver
(package
(name "python-pytest-httpserver")
- (version "1.0.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "pytest_httpserver" version))
- (sha256
- (base32
- "0vbls0j570l5my83j4jnk5blmnir44i0w511azlh41nl6k8rac5f"))))
- (build-system python-build-system)
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest_httpserver" version))
+ (sha256
+ (base32 "00c7vki5qpl40qn5riyppkjnmgrvhsbg0hsdp6qm3m9fkqcv073b"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pytest))
+ (list python-poetry-core
+ python-toml
+ python-pytest))
(propagated-inputs
(list python-werkzeug))
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-library-loading
- (lambda _
- (setenv "GUIX_PYTHONPATH" (string-append (getenv "GUIX_PYTHONPATH") ":."))))
- (replace 'check
- (lambda _
- (invoke "pytest" "tests" "-vv")
- (invoke "pytest" "tests" "-vv" "--ssl"))))))
(home-page "https://github.com/csernazs/pytest-httpserver")
(synopsis "HTTP server for pytest")
- (description "Pytest plugin library to test http clients without
-contacting the real http server.")
+ (description
+ "Pytest plugin library to test http clients without contacting the real
+http server.")
(license license:expat)))
(define-public python-pytest-nunit