summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-06 17:12:45 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:03 +0000
commit2b3539e3297b91b5d6f1c951134d3fbcc80a0ef4 (patch)
tree4b31efdc1eb87a7dd301a4e624258ec5f2963917 /gnu/packages/check.scm
parent53d60540fa39f3aff7679a48393d797c5ea92fff (diff)
gnu: python-behave-web-api: Update to 2.0.1.
* gnu/packages/check.scm (python-behave-web-api): Update to 2.0.1. [native-inputs]: Add python-pytest, python-setuptools, and python-wheel. Change-Id: If0202516a578a8fb90470dcc1a8d58c901f16169
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 654306c41c3..95afb11e222 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3408,15 +3408,15 @@ tests written in a natural language style, backed up by Python code.")
(define-public python-behave-web-api
(package
(name "python-behave-web-api")
- (version "1.0.6")
+ (version "2.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "behave-web-api" version))
(sha256
(base32
- "03kpq2xsy1gab3jy0dccbxlsg7vwfy4lagss0qldwmx3xz6b3i19"))))
- (build-system python-build-system)
+ "04p5sp6wck3mafj634w1fpvfhxm170l5q3hfb9d06pi71ql606n6"))))
+ (build-system pyproject-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -3426,6 +3426,10 @@ tests written in a natural language style, backed up by Python code.")
(("'wheel'") "") ; We don't use it.
(("'ordereddict==1.1'") "")) ; Python >= 2.7 has it built-in.
#t)))))
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list behave python-requests))
(home-page "https://github.com/jefersondaniel/behave-web-api")