summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-17 23:00:31 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-30 10:30:45 +0100
commitb5c33f99e3d1f42abf0c1f149a381ac9cc6c08f4 (patch)
tree83a0a94425830dbd076b10d8cf002471c265e819 /gnu/packages/check.scm
parent99b292a6534de895d3e6be09f3b7df74c2c4b565 (diff)
gnu: Add python-pytest-8.
* gnu/packages/check.scm (python-pytest-8): New variable. Change-Id: Ie584a48a2749cc7b196e373fe4e6e08f47165620
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index b8fbe3f6a80..21a975f340f 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1411,6 +1411,36 @@ and functions, detailed info on failing assert statements, modular fixtures,
and many external plugins.")
(license license:expat)))
+(define-public python-pytest-8
+ (package/inherit python-pytest
+ (name "python-pytest")
+ (version "8.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest" version))
+ (sha256
+ (base32 "0xvr25qvmdh6z03jpgg24adhgqkvkal2g2v8vk63j6909q8bhjyy"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "-k" (string-append
+ "not test_code_highlight_continuation"
+ " and not test_code_highlight"
+ " and not test_code_highlight_custom_theme"
+ " and not test_code_highlight_invalid_theme"
+ " and not test_code_highlight_invalid_theme_mode"
+ " and not test_code_highlight_simple"
+ " and not test_color_yes"
+ " and not test_comparisons_handle_colors"
+ " and not test_empty_NO_COLOR_and_FORCE_COLOR_ignored"
+ " and not test_remove_dir_prefix"))))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs python-pytest)
+ (append python-exceptiongroup)
+ (replace "python-pluggy" python-pluggy-next)))))
+
(define-public python-pytest-next
(package/inherit python-pytest
(name "python-pytest")