summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2024-02-22 20:47:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:25 +0000
commit6d97c15911a51d29f91e3656f9c4ab38e08d7f21 (patch)
treea42bcc8f38f2532ca0218d92323c993729912961 /gnu/packages/bioinformatics.scm
parent1ef178c644178304b24bd29c7563ab0529c15f8f (diff)
gnu: Add python-setuptools/python-wheel where necessary.
Changes to pyproject-build-system require explicit dependency on setuptools/wheel. Change-Id: Icd7699fc1dc56e974ae7568f2ae916dbf876bea5
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm23
1 files changed, 17 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 821be215c8..b22d2ffb57 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -682,6 +682,7 @@ memory usage.")
(list python-numpy python-pysam))
(inputs
(list r-minimal))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://wlcb.oit.uci.edu/cpat/")
(synopsis "Alignment-free distinction between coding and noncoding RNA")
(description
@@ -2084,7 +2085,7 @@ Format (GFF) with Biopython integration.")
python-scikit-learn
python-scipy))
(native-inputs
- (list python-pytest))
+ (list python-pytest python-setuptools python-wheel))
(home-page "https://github.com/simonvh/fluff/")
(synopsis "Analysis and visualization of high-throughput sequencing data")
(description
@@ -2894,6 +2895,7 @@ cells).")
(("'argparse',") "")))))
(build-system pyproject-build-system)
(propagated-inputs (list python-numpy python-pysam))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://github.com/cancerit/parabam")
(synopsis "Parallel BAM File Analysis")
(description "Parabam is a tool for processing sequencing files in
@@ -2962,6 +2964,7 @@ encountered in PDB files prior to simulation tasks.")
python-tqdm
python-typing-extensions
python-zipp))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://github.com/haessar/peaks2utr")
(synopsis "Python CLI for annotating three prime UTR")
(description
@@ -3325,7 +3328,8 @@ features:
python-pandas
python-pysam
python-tqdm))
- (native-inputs (list python-cython python-pytest))
+ (native-inputs (list python-cython python-pytest python-setuptools
+ python-wheel))
(home-page "https://github.com/KindLab/scDamAndTools")
(synopsis "Functions for processing raw scDam&T-seq data")
(description
@@ -3358,6 +3362,7 @@ counts.")
python-numpy
python-pybedtools
python-pysam))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://github.com/r3fang/SnapTools")
(synopsis "Tools for processing snap files" )
(description
@@ -3387,6 +3392,7 @@ operations:
(arguments (list #:tests? #false)) ;there are none
(propagated-inputs (list python-click python-numpy python-pandas
python-parabam python-pysam))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://github.com/cancerit/telomerecat")
(synopsis "Telomere computational analysis tool")
(description "Telomerecat is a tool for estimating the average telomere
@@ -5630,7 +5636,9 @@ annotations of the genome.")
python-pytest
python-pytest-mock
python-pytest-timeout
- python-setuptools-scm))
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(home-page "https://cutadapt.readthedocs.io/en/stable/")
(synopsis "Remove adapter sequences from nucleotide sequencing reads")
(description
@@ -5925,7 +5933,7 @@ accessing bigWig files.")
(("tests/data/" m)
(string-append (getcwd) "/" m))))))))
(propagated-inputs (list python-numpy))
- (native-inputs (list python-nose))
+ (native-inputs (list python-nose python-setuptools python-wheel))
(home-page "https://github.com/brentp/pyfasta/")
(synopsis "Pythonic access to fasta sequence files")
(description
@@ -9189,7 +9197,7 @@ experiments.")
(propagated-inputs
(list python-cython python-numpy))
(native-inputs
- (list python-pytest))
+ (list python-pytest python-setuptools python-wheel))
(home-page "https://github.com/macs3-project/MACS")
(synopsis "Model based analysis for ChIP-Seq data")
(description
@@ -16378,6 +16386,7 @@ mapped paired-end sequencing reads.")
python-cython
python-msgpack
python-pysam))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://pypi.org/project/genomic-regions/")
(synopsis "Consistently handle genomic regions")
(description "This package aims to simplify working with genomic region /
@@ -20999,7 +21008,9 @@ updated much more frequently.")
python-tqdm))
(native-inputs
(list python-pytest
- python-setuptools-scm))
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(home-page "https://github.com/aertslab/ctxcore")
(synopsis "Core functions for pycisTarget and the SCENIC tool suite")
(description