summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-23 19:53:55 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:58 +0000
commit3c2943b621c05899aa59f0932b8e1d1053869db1 (patch)
tree22f9feccdedc63c07f972f2de6be05c88f7d2cde /gnu/packages/bioinformatics.scm
parent5f49430d303a88407c71506f5a7dac8eb8f877cf (diff)
gnu: build-system/pyproject: Add missing native-inputs.
* gnu/packages/bioinformatics.scm (python-ega-download-client) [native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/databases.scm (datasette)[native-inputs]: Add python-pip. * gnu/packages/django.scm (python-django-localflavor, python-django-contact-form)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/graphviz.scm (python-uqbar)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/jupyter.scm (python-jupyterlab-server)[native-inputs]: Add python-wheel. (python-nbstripout)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/machine-learning.scm (python-captum, python-linear-operator, python-gpytorch)[native-inputs]: Add python-setuptools. * gnu/packages/music.scm (abjad, abjad-ext-rmarkers, abjed-ext-nauert, python-mutagen)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/package-management.scm (python-conda-package-handling)[native-inputs]: Add python-setuptools and python-wheel. (conda)[native-inputs]: Add python-wheel. * gnu/packages/python-check.scm (python-pyinstrument, python-pytest-testmon, python-pytest-trio, python-nbval, python-pytest-toolbox)[native-inputs]: Add python-setuptools and python-wheel. (python-nptyping)[native-inputs]: Add python-setuptools. * gnu/packages/python-check.scm (python-dask-expr)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/python-web.scm (parfive, python-aioftp, python-hupper, python-sanic, python-mechanicalsoup, python-tinycss, python-aiostream, python-cbor2, gunicorn)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/python-xyz.scm (python-apprise, python-jaraco-classes, python-sparse, python-shtab, python-pyan3)[native-inputs]: Add python-setuptools. (python-jupytext, python-orderedmultidict, python-identify, python-nodeenv, python-cfgv, python-zarr, python-multipart, python-nbconvert, python-cram, python-immutables, python-numpydoc, python-cairosvg, python-unidecode, python-black, python-multidict, python-mpv-jsonipc, python-humanize, python-cmd2)[native-inputs]: Add python-setuptools and python-wheel. (python-partd, python-dask, python-zarr)[native-inputs]: Add python-wheel. (python-nbconvert)[propagated-inputs]: Add texlive-etoolbox. Remove duplicate textlive-jknapltx. (python-isort)[native-inputs]: Add python-pip. * gnu/packages/simulation.scm (python-fenics-dijitso)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/sphinx.scm (python-pydata-sphinx-theme, python-sphinx-autodoc-typehints)[native-inputs]: Add python-setuptools. * gnu/packages/syndication.scm (tuir)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/terminals.scm (python-halo)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/time.scm (python-arrow, python-dateutil) [native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/version-control.scm (pre-commit)[native-inputs]: Add python-setuptools and python-wheel. Remove input labels. * gnu/packages/virtualization.scm (python-qemu-qmp, python-transient)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/xorg.scm (python-xcffib)[native-inputs]: Add python-setuptools and python-wheel. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Change-Id: Id61cf8cdc47bd4c2871c0a9c8e9a5bfd51157df0
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b22d2ffb57..f1d44d870a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3285,8 +3285,14 @@ the managed genomes, STAR indexing and mapping and more.")
(("==") ">=")))))))
(propagated-inputs (list python-htsget python-psutil python-requests
python-tqdm python-urllib3))
- (native-inputs (list python-coverage python-pytest python-pyfakefs
- python-responses python-mock))
+ (native-inputs
+ (list python-coverage
+ python-mock
+ python-pyfakefs
+ python-pytest
+ python-responses
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/EGA-archive/ega-download-client")
(synopsis "EGA download client")
(description "PyEGA3 is a tool for viewing and downloading files from