summaryrefslogtreecommitdiff
path: root/gnu/packages/authentication.scm
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2024-11-17 16:29:59 +0100
committerEkaitz Zarraga <ekaitz@elenq.tech>2024-12-06 14:27:55 +0100
commit0c5d7b8480234f739448956f508307e64e8e45fa (patch)
tree9ca159ecdaf70340fa0851c45bac5c489958a32a /gnu/packages/authentication.scm
parentd75d1fe6ac7ded7e61322d18b07d347beb609aa0 (diff)
gnu: Update otpclient to 4.0.2
Requires updating `libcotp` to 3.1.0, that introduced a new way for testing that requires `criterium`, a package we don't have and that has dependencies that we don't have either. As the tests in `libcotp` are not an exhaustive testsuite and `otpclient` is its only dependent package, tests are disabled for the moment. * gnu/packages/authentication.scm (libcotp): Update to 3.1.0 [arguments] Disable tests. * gnu/packages/password-utils.scm (otpclient): Update to 4.0.2 Change-Id: Ie6d37b5efe59397d4979c7490b94f1c871c27d6d
Diffstat (limited to 'gnu/packages/authentication.scm')
-rw-r--r--gnu/packages/authentication.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/authentication.scm b/gnu/packages/authentication.scm
index da778de4cb7..d6b5cedb202 100644
--- a/gnu/packages/authentication.scm
+++ b/gnu/packages/authentication.scm
@@ -39,7 +39,7 @@
(define-public libcotp
(package
(name "libcotp")
- (version "2.0.1")
+ (version "3.1.0")
(source
(origin
(method git-fetch)
@@ -48,8 +48,14 @@
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "12ps2msclcbv53gjf936cny10an8sc70b9frp6xxjirfn5jg2h63"))))
+ (base32 "1lw15blzzds3qq4ydhi6fsk189p1rbvzy5fzz4r3fv6wlmcyyprs"))))
(build-system cmake-build-system)
+ (arguments `(#:tests? #f))
+ ;; TODO: tests:
+ ;; Tests can be built with -DBUILD_TESTS=on.
+ ;; Tests don't have a general `check` target so they have to be run manually.
+ ;; Tests require `criterion`, which is not included in guix and has several
+ ;; bundled dependencies.
(inputs (list libgcrypt))
(native-inputs (list pkg-config))
(home-page "https://github.com/paolostivanin/libcotp")