summaryrefslogtreecommitdiff
path: root/gnu/packages/antivirus.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-11-06 00:14:53 +0100
committerEfraim Flashner <efraim@flashner.co.il>2025-01-07 10:16:41 +0200
commitf8c6d5cbf1012501a55bbbfd9d6e3811d68f1f74 (patch)
treecf423ec750b6dc5f8d6cfef6985ad13842414c2a /gnu/packages/antivirus.scm
parent5112cf590f7539d844d9a1ce53fb5d45bb0dd490 (diff)
gnu: clamav: Add release-monitoring-url property.
* gnu/packages/antivirus.scm (clamav) [source]<uri>: Add secondary release URI. [properties]: Add release-monitoring-url. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: Ic34e5957819c94a0101c09f6854531e6c62bae89
Diffstat (limited to 'gnu/packages/antivirus.scm')
-rw-r--r--gnu/packages/antivirus.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/antivirus.scm b/gnu/packages/antivirus.scm
index d061b18b11..2161d60398 100644
--- a/gnu/packages/antivirus.scm
+++ b/gnu/packages/antivirus.scm
@@ -48,8 +48,13 @@
(version "0.103.11")
(source (origin
(method url-fetch)
- (uri (string-append "https://www.clamav.net/downloads/production/"
- "clamav-" version ".tar.gz"))
+ (uri
+ (list
+ (string-append "https://www.clamav.net/downloads/production/"
+ "clamav-" version ".tar.gz")
+ (string-append "https://github.com/Cisco-Talos/clamav/"
+ "releases/download/clamav-" version
+ "/clamav-" version ".tar.gz")))
(sha256
(base32
"04by1g3p6awhi3j1y6zpwzmasdnvjgi6lwm34l2gadlwgkdfpmv1"))
@@ -144,6 +149,8 @@ scanning on mail gateways. It provides a number of utilities including a
flexible and scalable multi-threaded daemon, a command line scanner, and
advanced tool for automatic database updates. The core of the package is an
anti-virus engine available in the form of a shared library.")
+ (properties `((release-monitoring-url
+ . "https://github.com/Cisco-Talos/clamav/releases")))
(license (list license:gpl2+ ;ClamAV itself
license:lgpl2.1 ;libclamav/mspack.[ch]
license:public-domain ;libclamav/7z/*, libclamav/rijndael.[ch], etc...