summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorvicvbcun <guix@ikherbers.com>2024-12-22 17:26:55 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2025-01-01 13:05:04 +0100
commit2d0faf10adb6ca49ae7ee84bf8eb0ab2c5e95066 (patch)
tree48faf7c1829f4f5b93e144f242ac5e56a3b0ac7a /gnu/packages/algebra.scm
parent806d23693a4c6c07689e5c122b6b5e06feb7d7bd (diff)
gnu: pari-gp: Use G-Expressions.
* gnu/packages/algebra.scm (pari-gp)[arguments]: Use G-Expressions. Unset make-flags. Change-Id: Id2be46acd67b474d6fdb8935070ffb243e87f920 Co-authored by: Vinicius Monego <monego@posteo.net> Change-Id: I7be07998e9e2d1fe9194d4af6a57537467f5e097 Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 4d7b4001cd..32834f1c15 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -245,16 +245,15 @@ the real span of the lattice.")
(native-inputs (list (texlive-updmap.cfg)))
(inputs (list gmp libx11 perl readline))
(arguments
- '(#:make-flags '("all")
- #:test-target "dobench"
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "./Configure"
- "--mt=pthread"
- (string-append "--prefix="
- (assoc-ref outputs "out"))))))))
+ (list
+ #:test-target "dobench"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "./Configure"
+ "--mt=pthread"
+ (string-append "--prefix=" #$output)))))))
(synopsis "PARI/GP, a computer algebra system for number theory")
(description
"PARI/GP is a widely used computer algebra system designed for fast