summaryrefslogtreecommitdiff
path: root/gnu/packages/aidc.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-05-24 12:31:45 +0800
committerAndrew Tropin <andrew@trop.in>2024-09-07 18:12:20 +0400
commit56cc832d076173152a718b18875b188ea23d21d0 (patch)
tree79b854a19f0def36a94be0a50d24b9ad6d1c9fc1 /gnu/packages/aidc.scm
parent3863c0b8c113636ca323cf4b64f8872e011c8df7 (diff)
gnu: qrcodegen-cpp: Update to 1.8.0.
* gnu/packages/aidc.scm (qrcodegen-cpp): Update to 1.8.0. [source]: Use qrcodegen-cpp-cmake.patch. [build-system]: Switch to cmake-build-system. [arguments]: Enable tests and build shared libraries. * gnu/packages/patches/qrcodegen-cpp-make-install.patch: Remove file. * gnu/packages/patches/qrcodegen-cpp-cmake.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch. Change-Id: I0272a28ab2cda89700b5523e96f3014eff7ebf65 Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages/aidc.scm')
-rw-r--r--gnu/packages/aidc.scm22
1 files changed, 7 insertions, 15 deletions
diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
index b0fc1b30d9..bc9c47a480 100644
--- a/gnu/packages/aidc.scm
+++ b/gnu/packages/aidc.scm
@@ -228,30 +228,22 @@ Python as well as GUI widgets for GTK and Qt.")
(define-public qrcodegen-cpp
(package
(name "qrcodegen-cpp")
- (version "1.6.0")
+ (version "1.8.0")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/nayuki/QR-Code-generator")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
- (patches (search-patches "qrcodegen-cpp-make-install.patch"))
+ (patches (search-patches "qrcodegen-cpp-cmake.patch"))
(sha256
(base32
- "0iq9sv9na0vg996aqrxrjn9rrbiyy7sc9vslw945p3ky22pw3lql"))))
- (build-system gnu-build-system)
+ "0dk9ci5gchxa8gh0hyhlj3d5jwxqlnfm85xyp791ldaia14bkj39"))))
+ (build-system cmake-build-system)
(arguments
- `(#:tests? #f ; no test suite
- #:make-flags
- (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure) ; No ./configure script
- ;; Only build the C++ variant.
- (add-after 'unpack 'chdir
- (lambda _
- (chdir "cpp")
- #t)))))
+ (list #:configure-flags
+ #~'("-DBUILD_TESTS=ON"
+ "-DBUILD_SHARED_LIBS=ON")))
(synopsis "QR Code generator library")
(description "qrcodegen-cpp is a QR code generator library in C++. The
project also offers Java, Javascript, Python, C, and Rust implementations.")