summaryrefslogtreecommitdiff
path: root/gnu/home
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-12-13 23:14:03 +0100
committerLudovic Courtès <ludo@gnu.org>2025-01-16 22:32:11 +0100
commitf68060a10182f4ff02eebaa2c426124eb92f97d8 (patch)
treef265c2842b986e23a36d1447c42413fea2c7c3b6 /gnu/home
parentc785dfb5acbb467a996b04444693c3f6209e63af (diff)
home: services: Add log rotation service.
* gnu/home/services/admin.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * doc/guix.texi (Shepherd Home Service): Document it. Change-Id: I37ac171147c236b05d6d3b226e9072ab7524dfe9
Diffstat (limited to 'gnu/home')
-rw-r--r--gnu/home/services/admin.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/home/services/admin.scm b/gnu/home/services/admin.scm
new file mode 100644
index 00000000000..1cd398cc513
--- /dev/null
+++ b/gnu/home/services/admin.scm
@@ -0,0 +1,31 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu home services admin)
+ #:use-module (gnu home services)
+ #:use-module (gnu services)
+ #:use-module (gnu services admin)
+ ;; For the 'home-shepherd-service-type' mapping.
+ #:use-module (gnu home services shepherd)
+ #:export (home-log-rotation-service-type)
+ #:re-export (log-rotation-configuration))
+
+(define home-log-rotation-service-type
+ (service-type
+ (inherit (system->home-service-type log-rotation-service-type))
+ (default-value (for-home (log-rotation-configuration)))))