summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-07 20:17:57 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:38 +0000
commitd1df1a80f604f634ede753484bde51e873cb7e22 (patch)
tree7e984183e2ff22ff55660bea4e7e97c47f5c484e
parent976f3adb721fbf316b2c6564a631b2b40002b85d (diff)
gnu: Add python-uri-template.
* gnu/packages/python-xyz.scm (python-uri-template): New variable. Change-Id: I2ff3995bc5741da0147a335c5f14f169a8001153
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8214a6da15..c60f71cd50 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13254,6 +13254,35 @@ computing.")
texlive-xetex
texlive-xindy))))))
+(define-public python-uri-template
+ (package
+ (name "python-uri-template")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "uri-template" version))
+ (sha256
+ (base32 "1ixczlgnsjv2850r6w0cb2npwcwzdqri8njr1pi7v371cpmzh00f"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python3" "test.py")))))))
+ (native-inputs
+ (list python-setuptools
+ python-setuptools-scm
+ python-wheel))
+ (home-page "https://gitlab.linss.com/open-source/python/uri-template")
+ (synopsis "RFC 6570 URI Template Processor")
+ (description "This packages implements URI Template expansion in strict
+adherence to RFC 6570, but adds a few extensions.")
+ (license license:expat)))
+
(define-public python-urwid
(package
(name "python-urwid")