summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-27 13:28:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:19:41 +0200
commitbc88cf9c299de0450497a95aa4c108bc0fd462e7 (patch)
tree60411317462bea6044c64033544c9671ed8deb94
parentb18354b065057a846bb0141b8e3c5c72eef73afa (diff)
gnu: rust-cargo-edit: Update to 0.13.0.
* gnu/packages/rust-apps.scm (rust-cargo-edit): Update to 0.13.0. [source]: Remove patch. [arguments]: Remove custom phases. Don't skip the tests. Add cargo-test-flags. [cargo-inputs]: Add rust-tame-index-0.13, rust-cargo-test-macro-0.3, rust-cargo-test-support-0.3. Replace rust-snapbox-0.4 with 0.6. Remove rust-crates-index-0.19, rust-git2-0.17, rust-native-tls-0.2. [inputs]: Add curl, libgit2-1.8. Remove libgit2-1.6. * gnu/packages/patches/rust-cargo-edit-remove-ureq.patch: Remove file. gnu/local.mk (dist_patch_DATA): Remove it. Change-Id: I10001bec2ccf09cce2aadfc62b7fb9abdbdad137
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/rust-cargo-edit-remove-ureq.patch33
-rw-r--r--gnu/packages/rust-apps.scm28
3 files changed, 11 insertions, 51 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 077f09e683d..b9f2d43397b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2186,7 +2186,6 @@ dist_patch_DATA = \
%D%/packages/patches/rust-1.70-fix-rustix-build.patch \
%D%/packages/patches/rust-1.78-unwinding-fix.patch \
%D%/packages/patches/rust-1.81-fix-riscv64-bootstrap.patch \
- %D%/packages/patches/rust-cargo-edit-remove-ureq.patch \
%D%/packages/patches/rust-ring-0.17-ring-core.patch \
%D%/packages/patches/rust-ndarray-remove-blas-src-dep.patch \
%D%/packages/patches/rust-ndarray-0.13-remove-blas-src.patch \
diff --git a/gnu/packages/patches/rust-cargo-edit-remove-ureq.patch b/gnu/packages/patches/rust-cargo-edit-remove-ureq.patch
deleted file mode 100644
index 99c58103c76..00000000000
--- a/gnu/packages/patches/rust-cargo-edit-remove-ureq.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-This is modeled after the upstream commit which removes ureq as a dependency.
-
-diff --git a/Cargo.toml b/Cargo.toml
-index 5a787e1..27171c7 100644
---- a/Cargo.toml
-+++ b/Cargo.toml
-@@ -201,26 +201,3 @@ test-external-apis = []
- upgrade = ["cli"]
- vendored-libgit2 = ["git2/vendored-libgit2"]
- vendored-openssl = ["git2/vendored-openssl"]
--
--[target."cfg(any(target_arch = \"x86_64\", target_arch = \"arm\", target_arch = \"x86\", target_arch = \"aarch64\"))".dependencies.ureq]
--version = "2.7.1"
--features = [
-- "tls",
-- "json",
-- "socks",
-- "socks-proxy",
--]
--default-features = false
--
--[target."cfg(not(any(target_arch = \"x86_64\", target_arch = \"arm\", target_arch = \"x86\", target_arch = \"aarch64\")))".dependencies.native-tls]
--version = "^0.2"
--
--[target."cfg(not(any(target_arch = \"x86_64\", target_arch = \"arm\", target_arch = \"x86\", target_arch = \"aarch64\")))".dependencies.ureq]
--version = "2.7.1"
--features = [
-- "native-tls",
-- "json",
-- "socks",
-- "socks-proxy",
--]
--default-features = false
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 330be039305..97e8e45efca 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2481,34 +2481,30 @@ browsers.")
(define-public rust-cargo-edit
(package
(name "rust-cargo-edit")
- (version "0.12.2")
+ (version "0.13.0")
(source (origin
(method url-fetch)
(uri (crate-uri "cargo-edit" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "03lxi7z1n9xq287lqvqnhzg5r0yv1fi3569ryw3jqcrvv8nqs0c2"))
- (patches (search-patches "rust-cargo-edit-remove-ureq.patch"))))
+ "1mlzszj9sz0fy43xffrpram9nhyvlp4nx95jc5493jjmrqjrpfwz"))))
(build-system cargo-build-system)
(arguments
`(#:install-source? #f
- ;; error[E0463]: can't find crate for `cargo_test_macro`
- #:tests? #f
+ ;; Not all files included.
+ #:cargo-test-flags '("--" "--skip=::case")
#:cargo-inputs
(("rust-anyhow" ,rust-anyhow-1)
("rust-cargo-metadata" ,rust-cargo-metadata-0.15)
("rust-clap" ,rust-clap-4)
("rust-clap-cargo" ,rust-clap-cargo-0.12)
("rust-concolor-control" ,rust-concolor-control-0.0.7)
- ("rust-crates-index" ,rust-crates-index-0.19)
("rust-dunce" ,rust-dunce-1)
("rust-env-proxy" ,rust-env-proxy-0.4)
- ("rust-git2" ,rust-git2-0.17)
("rust-hex" ,rust-hex-0.4)
("rust-home" ,rust-home-0.5)
("rust-indexmap" ,rust-indexmap-1)
- ("rust-native-tls" ,rust-native-tls-0.2)
("rust-pathdiff" ,rust-pathdiff-0.2)
("rust-regex" ,rust-regex-1)
("rust-semver" ,rust-semver-1)
@@ -2516,6 +2512,7 @@ browsers.")
("rust-serde-derive" ,rust-serde-derive-1)
("rust-serde-json" ,rust-serde-json-1)
("rust-subprocess" ,rust-subprocess-0.2)
+ ("rust-tame-index" ,rust-tame-index-0.13)
("rust-termcolor" ,rust-termcolor-1)
("rust-toml" ,rust-toml-0.7)
("rust-toml-edit" ,rust-toml-edit-0.19)
@@ -2523,20 +2520,17 @@ browsers.")
#:cargo-development-inputs
(("rust-assert-cmd" ,rust-assert-cmd-2)
("rust-assert-fs" ,rust-assert-fs-1)
+ ("rust-cargo-test-macro" ,rust-cargo-test-macro-0.3)
+ ("rust-cargo-test-support" ,rust-cargo-test-support-0.3)
("rust-predicates" ,rust-predicates-3)
- ("rust-snapbox" ,rust-snapbox-0.4)
+ ("rust-snapbox" ,rust-snapbox-0.6)
("rust-trycmd" ,rust-trycmd-0.14)
- ("rust-url" ,rust-url-2))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'dont-default-to-vendored-libgit2
- (lambda _
- (substitute* "Cargo.toml"
- ((".*\"vendored-libgit2\".*") "")))))))
+ ("rust-url" ,rust-url-2))))
(native-inputs
(list pkg-config))
(inputs
- (list libgit2-1.6
+ (list curl
+ libgit2-1.8
libssh2
openssl
zlib))