summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-04 20:39:53 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:59 +0000
commitbb3dbcde48c6f19100726545c43687f0d37fa620 (patch)
treef7ca726e248123bdc676d1b5b348e376d57bb0de
parentebe35e6b73326b0029323b640d58f7b3be1373a8 (diff)
gnu: Remove python-mistune-next.
* gnu/packages/python-xyz.scm (python-mistune-next): Delete variable. * gnu/packages/bioinformatics.scm (python-schema-salad) [propagated-inputs]: Remove python-mistune-next; add python-mistune. * gnu/packages/mail.scm (python-hyperkitty): Likewise. * gnu/packages/syndication.scm (giara): Likewise. Change-Id: Iccf5ffde2b2c5a8c9b8e1c0e6ebd6fa7eab9f144
-rw-r--r--gnu/packages/bioinformatics.scm2
-rw-r--r--gnu/packages/mail.scm2
-rw-r--r--gnu/packages/python-xyz.scm22
-rw-r--r--gnu/packages/syndication.scm2
4 files changed, 3 insertions, 25 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f1d44d870a0..1e9fdd404a6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5996,7 +5996,7 @@ Note that this package has been deprecated in favor of @code{pyfaidx}.")
(propagated-inputs
(list python-cachecontrol
python-importlib-resources
- python-mistune-next
+ python-mistune
python-mypy-extensions
python-rdflib
python-requests
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 86ca8ff501f..9d752c74bce 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -3776,7 +3776,7 @@ which sends emails to HyperKitty, the official Mailman3 web archiver.")
python-django-rest-framework
python-flufl-lock
python-mailmanclient
- python-mistune-next
+ python-mistune
python-networkx
python-pytz
python-robot-detection))
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e8a7c69277e..558f46f6737 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15449,28 +15449,6 @@ It also removes useless @code{pass} statements.")
Python.")
(license license:bsd-3)))
-;; 2.0 is not released yet, but some packages have started using it.
-(define-public python-mistune-next
- (package
- (inherit python-mistune)
- (name "python-mistune-next")
- (version "2.0.4")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "mistune" version))
- (sha256
- (base32
- "024q9l6mgd37wa25w7dhskv1m3zsj5lf0w9cfyx7l9p2adhadq4y"))))
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv")))))))
- (native-inputs (list python-pytest))))
-
(define-public python-markdown
(package
(name "python-markdown")
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index b1b7e7d5940..c47205f7c53 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -215,7 +215,7 @@ cards.")
python
python-beautifulsoup4
python-dateutil
- python-mistune-next
+ python-mistune
python-pillow
python-praw
python-pygobject