summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-06 14:04:54 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:36 +0000
commitba4750dfd0772e6428810b5da2b411de2b78a201 (patch)
tree813a66f5e5ee3eb49af6bad02726c9fdc6e6c182
parent7f48addbaf5471f21e2cbed775d0274bece3ecd8 (diff)
gnu: python-pytest-xdist: Add setuptools and wheel.
* gnu/packages/check.scm (python-pytest-xdist)[native-inputs]: Add python-setuptools and python-wheel. Change-Id: I0aa7130a6e1bc0741edb164fd145bc20d754c007
-rw-r--r--gnu/packages/check.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index d4ff9ea98b..75ef0aa9f2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2117,7 +2117,11 @@ same arguments.")
;; Fails with OSError: cannot send to <Channel id=1 closed>
;; on foreign distribution.
'(list "-k" "not test_internal_errors_propagate_to_controller")))
- (native-inputs (list python-setuptools-scm python-filelock python-pytest))
+ (native-inputs (list python-filelock
+ python-pytest
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(propagated-inputs (list python-execnet python-pytest-forked))
(home-page "https://github.com/pytest-dev/pytest-xdist")
(synopsis