summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-04 20:34:35 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:34 +0000
commita2114bd514a66e911f17fd227f29c312f3e68892 (patch)
tree4b7c3fcc1a58b26b773bd41a77ad4ff4a3c72cea
parent9280f9f9b56f0debec10e2b688ba3e703484dd5b (diff)
gnu: python-mysqlclient: Add missing inputs.
* gnu/packages/databases.scm (python-mysqlclient)[native-inputs]: Add python-setuptools and python-wheel. Change-Id: Id0343382f1ef80b0299641e2b588e1687beeab30
-rw-r--r--gnu/packages/databases.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index ba75fd4235..25b4681617 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -4299,7 +4299,8 @@ files or Python scripts that define a list of migration steps.")
(list #:test-flags
#~'("tests/test__mysql.py" ;tests not needing a live db
"tests/test_MySQLdb_times.py")))
- (native-inputs (list pkg-config python-pytest))
+ (native-inputs
+ (list pkg-config python-pytest python-setuptools python-wheel))
(inputs (list mariadb-connector-c))
(home-page "https://github.com/PyMySQL/mysqlclient")
(synopsis "MySQLdb is an interface to the popular MySQL database server for Python")