summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-07 15:40:57 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:38 +0000
commita1504cde345d2a5c04c2cf639892ee655dfddc9a (patch)
tree521089196956535f66bc9e37c4dd87814e442382
parent34cd6beab0205d6734f96e33faeca449503e014f (diff)
gnu: Add python-overrides.
* gnu/packages/python-xyz.scm (python-overrides): New variable. Change-Id: I43f613195879ea6cdd5174daadb5e5c35569e534
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7f0fedd197..c02b09e3c0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3999,6 +3999,25 @@ dataclass, datetime, numpy, and UUID instances natively.")
;; Either of these licenses
(license (list license:asl2.0 license:expat))))
+(define-public python-overrides
+ (package
+ (name "python-overrides")
+ (version "7.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "overrides" version))
+ (sha256
+ (base32 "02l2j5pnsxn0q5i63is5g6i3q06ri83nf7lv55swr61vv6iqy5am"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-setuptools python-wheel))
+ (home-page "https://github.com/mkorpela/overrides")
+ (synopsis "Decorator to detect mismatch when overriding a method")
+ (description
+ "This package provides a decorator to automatically detect mismatch when
+overriding a method.")
+ (license license:asl2.0)))
+
(define-public python-argparse-addons
(package
(name "python-argparse-addons")