summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:46:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:24 +0200
commit9aeddf892a4133d9cf6d9d8baccc1e0186ce08af (patch)
tree95523deda2f6c18c046e78cd5e7eead451febfd3
parentd7156e3d43b5ed1851cd327ca4be0ded71c60807 (diff)
gnu: Add texlive-dirtree.
* gnu/packages/tex.scm (texlive-dirtree): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 31302a2a49..45af13ce50 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1517,6 +1517,28 @@ german. They draw up bibliographies in accordance with the german DIN 1505,
parts 2 and 3.")
(license license:public-domain)))
+(define-public texlive-dirtree
+ (package
+ (name "texlive-dirtree")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/dirtree/"
+ "source/generic/dirtree/"
+ "tex/generic/dirtree/")
+ (base32
+ "1righlip75ry0yc6kbpijq423k4m625byzgb55d32s7c0imvj41v")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/dirtree")
+ (synopsis "Display trees in the style of Windows Explorer")
+ (description
+ "This package is designed to emulate the way Windows Explorer displays
+directory and file trees, with the root at top left, and each level of subtree
+displaying one step in to the right. The macros work equally well with Plain
+TeX and with LaTeX.")
+ (license license:lppl)))
+
(define-public texlive-dosepsbin
(package
(name "texlive-dosepsbin")