summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-07 00:10:47 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:05 +0000
commit98101729837efa32843d8e584213e0df81faf3bd (patch)
treeac6d6e4170573ed21dda7b22b641f8cf46d18a2e
parenteffadb3177fe6fc1aef66bb9ed564596b892b687 (diff)
gnu: hangups: Fix build.
* gnu/packages/messaging.scm (hangups): Fix build. [build-system]: Swap to pyproject-build-system. [arguments]<phases>: Use default check phase. [native-inputs]: Add nss-certs-for-test, python-setuptools, and python-wheel. Change-Id: I00861c594156ef41b34892250b898f1ed585ae48
-rw-r--r--gnu/packages/messaging.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index e6c13de845..cb74f5f0b1 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2590,7 +2590,7 @@ QMatrixClient project.")
(uri (pypi-uri "hangups" version))
(sha256
(base32 "12mq22lygh6vz2h5dpvyjk18hx3jphb4kkavqsy298c7hw60hn7l"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -2599,11 +2599,13 @@ QMatrixClient project.")
(lambda _
(substitute* "setup.py"
(("==") ">=")
- ((",<.*'") "'"))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "hangups")))))))
+ ((",<.*'") "'")))))))
+ (native-inputs
+ (list nss-certs-for-test
+ python-httpretty
+ python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-aiohttp
python-appdirs
@@ -2615,8 +2617,6 @@ QMatrixClient project.")
python-reparser
python-requests
python-urwid))
- (native-inputs
- (list python-httpretty python-pytest))
(home-page "https://hangups.readthedocs.io/")
(synopsis "Instant messaging client for Google Hangouts")
(description