summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-07 21:26:52 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:37 +0000
commit976f3adb721fbf316b2c6564a631b2b40002b85d (patch)
treee465cca1265e14536beca74520f701af2254c2fc
parent3e331830219512ed112b61befeb3cd9353cc8ca3 (diff)
gnu: Add python-isoduration.
* gnu/packages/python-xyz.scm (python-isoduration): New variable. Change-Id: I3503ea0baf6a73a9b3c19ab616127ce5df1ed827
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f7aba9ebd6..8214a6da15 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24824,6 +24824,28 @@ builds partial trees by inspecting living objects.")
version, is suitable to be include as a dependency in other projects.")
(license license:lgpl3+)))
+(define-public python-isoduration
+ (package
+ (name "python-isoduration")
+ (version "20.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "isoduration" version))
+ (sha256
+ (base32 "1n8vpa9fckhc5934kp7m83wq81dhkvw987v7mjg2fdbr2car0bxc"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-arrow))
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://github.com/bolsote/isoduration")
+ (synopsis "Operations with ISO 8601 durations")
+ (description "ISO 8601 is most commonly known as a way to exchange
+datetimes in textual format. A lesser known aspect of the standard is the
+representation of durations. The state of the art of ISO 8601 duration
+handling in Python is more or less limited to what's offered by isodate. This
+package attempts to address the shortcomings of @code{isodate}.")
+ (license license:isc)))
+
(define-public python-isort
(package
(name "python-isort")