summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2024-02-13 14:15:42 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:31 +0000
commit7987f01baa98c946eefd3610bf8cea73679eb0f4 (patch)
tree59028cd30ddb50842b9575a817c50930e8673251
parentaa2771faff6ae48939670314170fcbbe6b67e37d (diff)
gnu: python-textual: Update to 0.50.1.
* gnu/packages/python-xyz.scm (python-textual): Update to 0.50.1. [source]: Download from github as pypi package does not include tests. [build-system]: Change to pyproject-build-system. [arguments]: Remove custom 'check phase; add #:test-flags to disable broken tests. [propagated-inputs]: Add python-markdown-it-py, python-mdit-py-plugins and python-tree-sitter. [native-inputs]: Add python-poetry-core and python-pytest-asyncio. Change-Id: Ib144dc87f73e91d4c9d2e8f91ce6ce7a86a481a9 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/python-xyz.scm47
1 files changed, 23 insertions, 24 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5a06edc35e..1a66faf98f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -286,6 +286,7 @@
#:use-module (gnu packages textutils)
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages tree-sitter)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
#:use-module (gnu packages web)
@@ -20715,20 +20716,8 @@ customization required.")
(define-public python-textual
(package
(name "python-textual")
- (version "0.1.18")
+ (version "0.50.1")
(source (origin
- (method url-fetch)
- (uri (pypi-uri "textual" version))
- (sha256
- (base32
- "08yg5a51hz1axfj5hx28hx31gq5apcj6vpkkmawmiplisa73z25j"))))
- (build-system python-build-system)
- (arguments
- (let ((tests
- ;; The release on pypi comes without tests. We can't build
- ;; from this checkout, though, because installation requires
- ;; an invocation of poetry.
- (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/Textualize/textual")
@@ -20736,19 +20725,29 @@ customization required.")
(file-name (git-file-name name version))
(sha256
(base32
- "0b3ycwqhp21mg9fvmadgxhgbvkwq6fd784l2xcmvy77rravrnnax")))))
- (list #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (copy-recursively #$(file-append tests "/tests")
- "tests")
- (invoke "python" "-m" "pytest" "-vv"))))))))
+ "10mmmgsq5pblr9ijgyln79p3hc7sah56k2hkzlvm2abrr9gwgpcf"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:test-flags
+ ;; Snapshot tests require python-pytest-textual-snapshot which
+ ;; in turn depends on python-textual.
+ '(list "--ignore=tests/snapshot_tests/test_snapshots.py"
+ "-k" (string-append
+ ;; Broken for unknown reason.
+ "not test_textual_env_var"
+ ;; Tests that require python-treesitter-languages.
+ " and not test_language_binary_missing"
+ " and not test_register_language"
+ " and not test_register_language_existing_language"))))
(propagated-inputs
- (list python-rich python-typing-extensions))
+ (list python-markdown-it-py
+ python-mdit-py-plugins
+ python-rich
+ python-tree-sitter
+ ;; python-tree-sitter-languages ; optional, not packed yet
+ python-typing-extensions))
(native-inputs
- (list python-pytest))
+ (list python-poetry-core python-pytest python-pytest-asyncio))
(home-page "https://github.com/Textualize/textual")
(synopsis "Build text user interfaces in Python")
(description "Textual is a @acronym{TUI, Text User Interface} framework