summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-27 19:41:56 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:32 +0000
commit56cbfffc4ed3323f3e63ea5934d1383386845559 (patch)
treed02c4fe82dc0bcaa60b335f57b6e9e76bcb7a92d
parent7fe8e4cfc541ccf821f1902be83418b4281f52f0 (diff)
gnu: python-cleo: Update to 2.1.0.
* gnu/packages/python-xyz.scm (python-cleo): Update to 2.1.0. [build-system]: Use pyproject-build-system. [native-inputs]: Add python-poetry-core. [propagated-inputs]: Remove python-backpack, python-clikit, python-pastel, and python-pylev; add python-crashtest and python-rapidfuzz. Change-Id: I3762a84a038d4cf571348986353e615ae6d944f7
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b6a6f67089..f8fba89a76 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21690,19 +21690,21 @@ Wikipedia code samples at
(define-public python-cleo
(package
(name "python-cleo")
- (version "0.8.1")
+ (version "2.1.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "cleo" version))
(sha256
(base32
- "17q6wi3q280kxmxzb2iwnnqih2xbljn18v0bjx2ip18p079j43ix"))))
- (build-system python-build-system)
+ "08ym7xaalxzka3k9wp7i05n6j9xmmjs1y02ilrz0lrhkbl5qhb0b"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list ;; For testing
- python-mock python-pytest-mock python-pytest))
+ (list python-poetry-core
+ python-mock
+ python-pytest-mock
+ python-pytest))
(propagated-inputs
- (list python-backpack python-clikit python-pastel python-pylev))
+ (list python-crashtest python-rapidfuzz))
(home-page "https://github.com/sdispater/cleo")
(synopsis "Command-line arguments library for Python")
(description