summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 17:45:13 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:49 -0400
commit42aa6229eb2e63c8082a8e1fe7be34f3818da421 (patch)
treeb85ec84574d90956f9888311b5161296a0955c83
parent08b026b3e3206dce0053c1998309859008d5458d (diff)
gnu: Remove python2-anyjson.
* gnu/packages/python-xyz.scm (python2-anyjson): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4900efee57..fcfd73ae16 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15953,17 +15953,7 @@ fast xml and html manipulation.")
(description
"Anyjson loads whichever is the fastest JSON module installed
and provides a uniform API regardless of which JSON implementation is used.")
- (license license:bsd-3)
- (properties `((python2-variant . ,(delay python2-anyjson))))))
-
-(define-public python2-anyjson
- (let ((anyjson (package-with-python2
- (strip-python2-variant python-anyjson))))
- (package/inherit anyjson
- (arguments `(;; Unlike the python 3 variant, we do run tests. See above!
- #:tests? #t
- ,@(package-arguments anyjson)))
- (native-inputs `(("python2-nose" ,python2-nose))))))
+ (license license:bsd-3)))
(define-public python-amqp
(package