summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-08-27 16:06:49 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-21 22:52:52 +0800
commit410ef3e6ce06229b70bd6fad953a05d1908c057f (patch)
tree382f1a9c6343ff71680774c3f02f0709febd67e8
parent753dbb1e1b51490f450228405d6f2a1b17c7a5aa (diff)
gnu: python-pyqt-builder: Update to 1.16.4.
* gnu/packages/qt.scm (python-pyqt-builder): Update to 1.16.4. [source]: Adjust pypi-url's name. [build-system]: Switch to pyproject-build-system. [native-inputs]: Add python-setuptools, python-setuptools-scm-next, and python-wheel. [arguments]: Disable tests. Change-Id: I2d1186536e9afb02de68c9fcb5e53d40eafa2ca0
-rw-r--r--gnu/packages/qt.scm40
1 files changed, 22 insertions, 18 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 267be4c59f0..45d96175298 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4253,26 +4253,30 @@ set of three modules.")))
(define-public python-pyqt-builder
(package
- (name "python-pyqt-builder")
- (version "1.14.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "PyQt-builder" version))
- (sha256
- (base32
- "00m5piryz9l4hp5z1ncaqicsp29kj71akdh4b10432zz18q3xg43"))))
- (build-system python-build-system)
- (inputs
- (list python-sip))
- (home-page "https://www.riverbankcomputing.com/static/Docs/PyQt-builder/")
- (synopsis "PEP 517 compliant PyQt build system")
- (description "PyQt-builder is a tool for generating Python bindings for C++
+ (name "python-pyqt-builder")
+ (version "1.16.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyqt_builder" version))
+ (sha256
+ (base32
+ "1pxgcqk9qf0qvszllb467v2cmr6ngksfr2caz1a2xgkrwcdf85a5"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-setuptools
+ python-setuptools-scm-next
+ python-wheel))
+ (inputs
+ (list python-sip))
+ (arguments (list #:tests? #f)) ; no test suite
+ (home-page "https://www.riverbankcomputing.com/static/Docs/PyQt-builder/")
+ (synopsis "PEP 517 compliant PyQt build system")
+ (description "PyQt-builder is a tool for generating Python bindings for C++
libraries that use the Qt application framework. The bindings are built on
top of the PyQt bindings for Qt. PyQt-builder is used to build PyQt itself.")
- ;; Either version 2 or 3, but no other version. See the file
- ;; 'pyqtbuild/builder.py' in the source distribution for more information.
- (license (list license:gpl2 license:gpl3))))
+ ;; Either version 2 or 3, but no other version. See the file
+ ;; 'pyqtbuild/builder.py' in the source distribution for more information.
+ (license (list license:gpl2 license:gpl3))))
(define-public python-qtpy
(package